summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-13 16:43:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:12 +0200
commit75dd10c7d9dc7f20e73445bf31cce819ae962cb2 (patch)
tree683855d5c9ea0c6c30bc35bff7803a4990b31290 /kde-frameworks/kdoctools
parentkde5.eclass: kde-frameworks/kdewebkit moved to portingAids (diff)
downloadgentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.tar.gz
gentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.tar.bz2
gentoo-75dd10c7d9dc7f20e73445bf31cce819ae962cb2.zip
kde-frameworks: Add KDE Frameworks 5.60.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdoctools')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.60.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index 26cc65aff8f9..2ed8c65cc735 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1,2 +1,3 @@
DIST kdoctools-5.57.0.tar.xz 426072 BLAKE2B 4446a883199b927904ea420eb01bc28301bb5a49c0ac1977229b2227a68c630f29156bdb26b1308abfc2fa30371663bd91a366e8aaa60ec0891b2c1dad7e6b07 SHA512 b4428e106414768d11cfa8cd285fca17b7ee088b89138f394a62ad5209ab89e9364d623180ccf73faad8e2ed902ec38dc4548259355ab1cebce75148de71a722
DIST kdoctools-5.59.0.tar.xz 427756 BLAKE2B b49add2de3f3d8f476f1fc058cd23ee2df203e9c7dc6daa5c6f93f4dcc5ef5eb3d789eb98b8ea1beeb11563dc99173b1a65d9c271b1ae9018da7a73e5c8df6e6 SHA512 f66db9c71e5181f03956257615a1260330d16133f2393c9dc3e2e157c64464abde9706cb2bcccc3ea7fd29bffaabe408ea02a6ed0e6cf2c1d248bd5379e1b738
+DIST kdoctools-5.60.0.tar.xz 426728 BLAKE2B b5fef9874fa07bc697cdb89d80f19d58f510b02c4d98d358920282b673c7be49644b1f38e8d48df7dcbb2b2d1ec920f1f6ea39df11f8939b996b310230fe1375 SHA512 0ef93030b14d99b95768370e4c9639bdbb2d5e31fa604ed216a101e372e0ccb9197c9f68eb961c7552e0a4e3523f5efc654d3c3a0bd8750539b866898a9f38fd
diff --git a/kde-frameworks/kdoctools/kdoctools-5.60.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.60.0.ebuild
new file mode 100644
index 000000000000..33355540123c
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.60.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_QTHELP="false"
+inherit kde5
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( $(add_frameworks_dep ki18n) )
+"
+DEPEND="
+ $(add_frameworks_dep karchive)
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package nls KF5I18n)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ kde5_src_test
+}