summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-16 10:51:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-18 10:25:27 +0200
commit1bbf229a48f93d355d2bb4660ff4f2c67704ca04 (patch)
tree22fae13a348a13af4e978a5688fe3ecbf27420c8 /kde-frameworks/kdoctools
parentkde-frameworks/kcrash: 5.109.0 version bump (diff)
downloadgentoo-1bbf229a48f93d355d2bb4660ff4f2c67704ca04.tar.gz
gentoo-1bbf229a48f93d355d2bb4660ff4f2c67704ca04.tar.bz2
gentoo-1bbf229a48f93d355d2bb4660ff4f2c67704ca04.zip
kde-frameworks/kdoctools: 5.109.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kdoctools')
-rw-r--r--kde-frameworks/kdoctools/Manifest1
-rw-r--r--kde-frameworks/kdoctools/kdoctools-5.109.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-frameworks/kdoctools/Manifest b/kde-frameworks/kdoctools/Manifest
index 43d15951a778..8c36941b0a19 100644
--- a/kde-frameworks/kdoctools/Manifest
+++ b/kde-frameworks/kdoctools/Manifest
@@ -1 +1,2 @@
DIST kdoctools-5.108.0.tar.xz 465352 BLAKE2B 25bd23e936524ca17ae17b640a5c42d3a91a3d48f86e1811404c9156934beb1c80dcafd7648df7d6258ea962fd6b18083bc364b0bc8d13c84216ac087b7c4044 SHA512 307bb472fa8bbb4165bce174fccb321498fde81e40aaa0f540c7cb9091674ae4f43210f9ad405e063a95ff3c0b518e0c0d609a03f82b3c3101ea29b6f47ed910
+DIST kdoctools-5.109.0.tar.xz 465404 BLAKE2B 8aa2013fa77748a100b1457cbf02bcd7a363332a1c14caada012fe28d047d4ace1e2c2bc734dcd15653670610c5c05283036f391e9fe8aeac2feca49b61c5e25 SHA512 6cb3166dd0328963f6893f3138cc452e45c405e639f461bc534cfc8151d10c4b3245ca1ff5f2ab924a35aba5a8776a0b0fcd19ebf4532828f5619062a8724aad
diff --git a/kde-frameworks/kdoctools/kdoctools-5.109.0.ebuild b/kde-frameworks/kdoctools/kdoctools-5.109.0.ebuild
new file mode 100644
index 000000000000..1058839aa23c
--- /dev/null
+++ b/kde-frameworks/kdoctools/kdoctools-5.109.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Tools to generate documentation in various formats from DocBook files"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/URI
+ nls? ( >=kde-frameworks/ki18n-${PVCUT}:5 )
+"
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/sgml-common
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ =kde-frameworks/karchive-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.54.0-gentoo-docbundledir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package nls KF5I18n)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bug 665622
+ local myctestargs=(
+ -E "(kdoctools_install)"
+ )
+
+ ecm_src_test
+}