summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 19:41:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-08 21:28:07 +0200
commit960b53f1cd249091348514ca4d444eb0ba967cfd (patch)
tree44882776b9db1882d72f47230991d1128a38b2d1 /kde-frameworks/kauth
parentmedia-gfx/kxstitch: 2.2.0 version bump (diff)
downloadgentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.gz
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.tar.bz2
gentoo-960b53f1cd249091348514ca4d444eb0ba967cfd.zip
kde-frameworks: Add KDE Frameworks 5.59.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.59.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 96d71721c896..c30b798b065d 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.57.0.tar.xz 85364 BLAKE2B 24eec6862a3d68e3abb7b16a2ed93d0b04484d782ecf5543092b382dc84e3935ff81073f077d3b87b68ea5fa2b95bfad4f8cc9572fbb2284ff152da3d450123e SHA512 7d5e2aee7c5f60cb1e30b1a54864ba79e61f3b79bda4c9efc8adb58b04e5723412156501583593087ca594a4348f8be7d569e2ef67747d95492b91b3c1cf5fec
DIST kauth-5.58.0.tar.xz 85388 BLAKE2B 55a02bce3c06b00c1d8cb6422550d170343934a2e339f3d358f8789bcaaf1fcc90c74cc6a5ef38a07f69a38c88af64588f88c1be957aa3cf605285279bbcee0f SHA512 7d337b4b6507dd1b35df118a5a1f9167efcec67386f85d0ed3c7f22dbb6c56fddf7ba4979c7f1c70c11b525f99a2e3e95e3a1d4f9971d8c02ce40e9664ee0cef
+DIST kauth-5.59.0.tar.xz 85392 BLAKE2B ac066ffd865afa9596174c5120bffdb27b95bae40fd96e21e77f13cb176cb9e6cab0e90e6e4fb354d5bd5fabb1444b5aebbcdd69bb806c23e700ef2d1ad04395 SHA512 c0f871da993cf7a44ef7bc5a06a393c4f5479dd26378de98812bfc9a14c6b017b04890735da8cf72ebbc4e3ab212e0a131a19ff5b8be28c64e4e8467b10de026
diff --git a/kde-frameworks/kauth/kauth-5.59.0.ebuild b/kde-frameworks/kauth/kauth-5.59.0.ebuild
new file mode 100644
index 000000000000..396d6cb72e1a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.59.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ kde5_src_test
+}