summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 00:21:01 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 10:19:23 +0200
commit832934f31e45d450d2eaee2a9ebd501303303c43 (patch)
tree26ddfbcde55dc86490c71053a6813be8c3a8c212 /kde-frameworks/kauth
parentmedia-gfx/digikam: Drop 6.1.0 (diff)
downloadgentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.gz
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.tar.bz2
gentoo-832934f31e45d450d2eaee2a9ebd501303303c43.zip
kde-frameworks: Add KDE Frameworks 5.61.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.61.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index d569511ce3ec..dfd9457bc970 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1 +1,2 @@
DIST kauth-5.60.0.tar.xz 85272 BLAKE2B 83c6e9901deb24413e0a3fe81812afb501a4c1517d550234a3945cdc520ba2ee5da4024571c9a25908090c5e8f083102c9ed554d94b81f86132f3c9c688ee146 SHA512 f35c904f22d04af26cca20fdc4c565203ef929e8efb7678aed8aa97d14d8be35e06a03e7db64a2bc4c17f9983072208fa4350c85790cca784bc4f1d81b2a7fd9
+DIST kauth-5.61.0.tar.xz 85756 BLAKE2B 2003fb8d92ec9b347fe87e3d3ee578d2c9103248388e273d62b704299bfd99a51a9d7671e59c7f60fd0f03e32ed4b8ec033ed550cc54c49eca7ecb9cb2b87a19 SHA512 3865181b846c671cbf357d8dd34e3c7bc18f71a8f73fd435523d7f6d96596dd9bf4e469f9d3308bd406f0587f0a338cdbec759b76d7a2105d47ab56ddd678b8f
diff --git a/kde-frameworks/kauth/kauth-5.61.0.ebuild b/kde-frameworks/kauth/kauth-5.61.0.ebuild
new file mode 100644
index 000000000000..396d6cb72e1a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.61.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ kde5_src_test
+}