summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-10 20:42:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-12 23:10:28 +0100
commit7614d59a31605680defee7a1ac2fdb413462f4a5 (patch)
treec0c111b5299d5a3cc29909f337c95f00184e5877 /kde-frameworks/frameworkintegration
parentapp-portage/gander: drop older ebuilds (diff)
downloadgentoo-7614d59a31605680defee7a1ac2fdb413462f4a5.tar.gz
gentoo-7614d59a31605680defee7a1ac2fdb413462f4a5.tar.bz2
gentoo-7614d59a31605680defee7a1ac2fdb413462f4a5.zip
kde-frameworks/frameworkintegration: 5.89.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.89.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 2d10013aa0cd..b4fd6abe0a9b 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.85.0.tar.xz 1755792 BLAKE2B 0a9b6b9a35d20fac0d07cbcf23f4ca1e0627a0175a7298a6b6391b1f4e1c38a46e029dc21ff22ea397ad3de053485097137e5a0de818300000f0c0e4f03c474e SHA512 d496c3b2ff49a3e4ee43e3c208b7dd3df68561fed0fe519f22a163c3389683f7d776270fc6472f4b52677cf85eb4a73c6bb7bdeea951600f8f5302411677a4f3
DIST frameworkintegration-5.88.0.tar.xz 1756084 BLAKE2B 38b827ab48b5c3e5ca98f9fafc022e6ad33eb056a2ffe2f6e82490c0c155984f54cde4fdb2a91af5709341b78977e14222c94af86d9127ac1710a51f46502607 SHA512 50944c4eaf40213cbb25f19bd35fa1e410778791c8a993b75ffed922f8e07d984735a0a6362bb2598dca085be7739e4981d0469bd07783b2276d3bb564274e0d
+DIST frameworkintegration-5.89.0.tar.xz 1758252 BLAKE2B 8cae071f43d140cb08c22e23eab8fdad44bed7aa115ed0316062fb006417c3f2393db032e9e6f4b6c71a935d51786a19ec7116c5a01bf5f62ee8d4894688b184 SHA512 9e0842c559bbd633a860fd2f4f93540efa1fc4b0ecc8c37ce99f4f3e4ac00e40163cd827af9d9acb3d74808214c81ccc9e9e91fec1b3aa2ac9d50d054f16e508
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.89.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.89.0.ebuild
new file mode 100644
index 000000000000..d52fad501353
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.89.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}