summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-11 20:39:02 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-11 20:40:40 +0100
commit5b1e795a660571baff9677500df7a83d0da1f9fc (patch)
treec04fa92ab286b19fbea1606698c58016aca4a9d4 /kde-frameworks/frameworkintegration
parentprofiles: Mask ktexteditor[editorconfig] on arm (diff)
downloadgentoo-5b1e795a660571baff9677500df7a83d0da1f9fc.tar.gz
gentoo-5b1e795a660571baff9677500df7a83d0da1f9fc.tar.bz2
gentoo-5b1e795a660571baff9677500df7a83d0da1f9fc.zip
kde-frameworks: Version bump KDE Frameworks 5.32.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.32.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 1f0b85facbe8..1627cc3ba91f 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.29.0.tar.xz 1750692 SHA256 ebb89e4b236163c067402cf78d67cddc443ef4fda0778001980948efc3cf5a52 SHA512 07cc7665a3604cbfae827cc28c64a966c7c62558903c40f1ce61be588d016de77e011489978ee3aa2b2583e061bbe37af0067d811b79dfddf5887113a3a56565 WHIRLPOOL d9da119a97fb0804d405208a823aa6f55f84f45891ddd322f508efca542dcd5e259aa89d0104eea46093e28e8eeee57ed1b589bc1f11312e6d4ddd1beea4245f
DIST frameworkintegration-5.31.0.tar.xz 1751940 SHA256 92bd369659312fac2ea3fbbeb086ad411d37643f8a1d4f033713541782b7d1f1 SHA512 cfde4b167eda1617e271d2b96e6bd9f607a3edbb1401deb063cc03fb27b313bd5ef10d733e0c078490be078b1b72e5a93de2074989ba73b2127480982f014655 WHIRLPOOL df1a562cddee4a358029c438ed1424e783f55a36b3bd6ba989ea1a4a6181dc549ef6b86970f3876f822dcf8c318083d98b9d42b8d07c2c95297a0e43914abe9c
+DIST frameworkintegration-5.32.0.tar.xz 1751920 SHA256 8a5ff514aaa73c4fbf616be45be9be9a2699d80c3409ccc749c8d07709635a08 SHA512 2255e50d7bcfabac97dc1b626b3722c5b27a540beb4be2f019f81d2bd467c850b4439514f85f090350a158ac375912ff3991df022f0161de677af36d2c4f1338 WHIRLPOOL 892736c170b7a9fd08c9fb50ae1d6a8cd88bc8099c181fd19bb13944ca6e69b71300a2be56b84a9f40eb348b07a73d13ae07c054135ca9e84cd563c31dfb164c
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.32.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.32.0.ebuild
new file mode 100644
index 000000000000..736635e23d9f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.32.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}