summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 12:07:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 22:07:39 +0100
commit574d461720532235cc2c35d394a88909ed9c9fe8 (patch)
tree3c14e61f21a67f6ef17e37f3c7273b16cadd7916 /kde-frameworks/frameworkintegration
parentecm.eclass: Use new ecm_punt_kf_module/ecm_punt_qt_module internally (diff)
downloadgentoo-574d461720532235cc2c35d394a88909ed9c9fe8.tar.gz
gentoo-574d461720532235cc2c35d394a88909ed9c9fe8.tar.bz2
gentoo-574d461720532235cc2c35d394a88909ed9c9fe8.zip
kde-frameworks/frameworkintegration: 5.90.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.90.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b030b372b493..a9ab096751a9 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.88.0.tar.xz 1756084 BLAKE2B 38b827ab48b5c3e5ca98f9fafc022e6ad33eb056a2ffe2f6e82490c0c155984f54cde4fdb2a91af5709341b78977e14222c94af86d9127ac1710a51f46502607 SHA512 50944c4eaf40213cbb25f19bd35fa1e410778791c8a993b75ffed922f8e07d984735a0a6362bb2598dca085be7739e4981d0469bd07783b2276d3bb564274e0d
DIST frameworkintegration-5.89.0.tar.xz 1758252 BLAKE2B 8cae071f43d140cb08c22e23eab8fdad44bed7aa115ed0316062fb006417c3f2393db032e9e6f4b6c71a935d51786a19ec7116c5a01bf5f62ee8d4894688b184 SHA512 9e0842c559bbd633a860fd2f4f93540efa1fc4b0ecc8c37ce99f4f3e4ac00e40163cd827af9d9acb3d74808214c81ccc9e9e91fec1b3aa2ac9d50d054f16e508
+DIST frameworkintegration-5.90.0.tar.xz 1758208 BLAKE2B c8a7a11677ca77032be1ef1491ba5d8efa356caf6e7704b240a50baec7119b64ba85d4d183692164a1de58ee42c8d92686c9abe3d14af0bd8493ff747d9ddb7f SHA512 4f27d8aa453ab5d08e410db4c93bd86386159bb3e82a65cff0c4264ec3467f916a761e7cc0f68365c3f821cce8c84ff6277afb975a967fe26ed7a545155defca
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.90.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.90.0.ebuild
new file mode 100644
index 000000000000..035cdd529c64
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.90.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}