summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/ksplash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/Manifest3
-rw-r--r--kde-base/ksplash/ksplash-4.11.14.ebuild39
-rw-r--r--kde-base/ksplash/ksplash-4.11.19.ebuild39
-rw-r--r--kde-base/ksplash/ksplash-4.11.21.ebuild39
-rw-r--r--kde-base/ksplash/metadata.xml5
5 files changed, 125 insertions, 0 deletions
diff --git a/kde-base/ksplash/Manifest b/kde-base/ksplash/Manifest
new file mode 100644
index 000000000000..8126fee160e2
--- /dev/null
+++ b/kde-base/ksplash/Manifest
@@ -0,0 +1,3 @@
+DIST kde-workspace-4.11.14.tar.xz 13529808 SHA256 cf20a562f3abf848ab0e122d6af1971dcc6383b91565f6da21f46f1011386e01 SHA512 203a5ffe1eea6f6d3e70fdcded0ac1fc86f76f8a175c043beddb5cbfaa865a07d53b6c1be55d63f4ff47946757267f390318cfad41bb0006f10462e8ec47dea7 WHIRLPOOL dd91f268701de19108eac235a12047aabf319189ce927dea1a60450183878ed454110b4a9d5bfa9613fa7732c8ac7f1344dc8cbc2d12d0b29c42b05e725183a2
+DIST kde-workspace-4.11.19.tar.xz 13547744 SHA256 1c1429db0a12d6ad076e0f1c6f1a00cac781aceb1aa8c88937fbf2700dc2c5c2 SHA512 37fad2704347bb123d05fbefe35ab73a24641baf83bc3486c2d8078ef0c601a1ef0438261040feefe8ee1d4341e7fa453d3412ccbb6e00d60ce7992ca5e5ac38 WHIRLPOOL 9a95bbad4c14988316c4c6c93738e5c945d6d4b1628c037edb46387c78abbc878ae6482ebec825257e30d5a0349e85db6261fdbf14100f798de6f2ca978a57ee
+DIST kde-workspace-4.11.21.tar.xz 13550508 SHA256 7196c68802af335b15a3b8e14c55a15ed7c2c0e9145a047dc6d4a281fe7f7c8f SHA512 6e4244177564bb497b2ab0ef5a6e98bdbc2629d8118af16d3cbb08d20d3e3cb6d9433c48c85e0b999226c02950a7a296eb2dbbb6f0bb3e1931300b18f64f5321 WHIRLPOOL c24bea247f39927aad8d80a6cf6dcb967ad4d650000877fb8d962fd9091626e49d776b2e4a99943d4ce1c40226c2827f346f5f2478d95208ba1e7ac609ff415d
diff --git a/kde-base/ksplash/ksplash-4.11.14.ebuild b/kde-base/ksplash/ksplash-4.11.14.ebuild
new file mode 100644
index 000000000000..756d6d193b54
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse
+cpu_flags_x86_sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_has cpu_flags_x86_3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has cpu_flags_x86_mmx X86_MMX)
+ $(cmake-utils_use_has cpu_flags_x86_sse X86_SSE)
+ $(cmake-utils_use_has cpu_flags_x86_sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/ksplash/ksplash-4.11.19.ebuild b/kde-base/ksplash/ksplash-4.11.19.ebuild
new file mode 100644
index 000000000000..1052d935776b
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.19.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse
+cpu_flags_x86_sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_has cpu_flags_x86_3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has cpu_flags_x86_mmx X86_MMX)
+ $(cmake-utils_use_has cpu_flags_x86_sse X86_SSE)
+ $(cmake-utils_use_has cpu_flags_x86_sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/ksplash/ksplash-4.11.21.ebuild b/kde-base/ksplash/ksplash-4.11.21.ebuild
new file mode 100644
index 000000000000..1838622d58c8
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.21.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_x86_3dnow altivec debug cpu_flags_x86_mmx cpu_flags_x86_sse
+cpu_flags_x86_sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_has cpu_flags_x86_3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has cpu_flags_x86_mmx X86_MMX)
+ $(cmake-utils_use_has cpu_flags_x86_sse X86_SSE)
+ $(cmake-utils_use_has cpu_flags_x86_sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/ksplash/metadata.xml b/kde-base/ksplash/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-base/ksplash/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>