summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-02 23:48:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-03 00:32:36 +0200
commit162fa47c3f48c4c9ee29527086cfc482f4785280 (patch)
tree40ea1e7b6542bdeae3908916e2767fb8e7c15036 /kde-apps
parentdev-perl/File-Next: Remove old re bug #615690 (diff)
downloadgentoo-162fa47c3f48c4c9ee29527086cfc482f4785280.tar.gz
gentoo-162fa47c3f48c4c9ee29527086cfc482f4785280.tar.bz2
gentoo-162fa47c3f48c4c9ee29527086cfc482f4785280.zip
kde-apps/libkleo: Fix build with GCC-6.3
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/libkleo/files/libkleo-4.4.2017.04-gcc-6.3.patch39
-rw-r--r--kde-apps/libkleo/libkleo-4.4.2017.04.ebuild2
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/libkleo/files/libkleo-4.4.2017.04-gcc-6.3.patch b/kde-apps/libkleo/files/libkleo-4.4.2017.04-gcc-6.3.patch
new file mode 100644
index 000000000000..79023520d73d
--- /dev/null
+++ b/kde-apps/libkleo/files/libkleo-4.4.2017.04-gcc-6.3.patch
@@ -0,0 +1,39 @@
+commit 272601864851e4411421ffe7fce764e01b5b1bfa
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Wed May 3 00:16:05 2017 +0200
+
+ libkleo: Fix build with GCC-6.3
+
+ Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
+
+diff --git a/libkleo/backends/qgpgme/qgpgmekeylistjob.cpp b/libkleo/backends/qgpgme/qgpgmekeylistjob.cpp
+index 4d26eb8772..c9c4642c62 100644
+--- a/libkleo/backends/qgpgme/qgpgmekeylistjob.cpp
++++ b/libkleo/backends/qgpgme/qgpgmekeylistjob.cpp
+@@ -85,7 +85,7 @@ static QGpgMEKeyListJob::result_type list_keys( Context * ctx, QStringList pats,
+ if ( pats.size() < 2 ) {
+ std::vector<Key> keys;
+ const KeyListResult r = do_list_keys( ctx, pats, keys, secretOnly );
+- return make_tuple( r, keys, QString(), Error() );
++ return boost::make_tuple( r, keys, QString(), Error() );
+ }
+
+ // The communication channel between gpgme and gpgsm is limited in
+@@ -109,7 +109,7 @@ retry:
+ chunkSize /= 2;
+ if ( chunkSize < 1 )
+ // chunks smaller than one can't be -> return the error.
+- return make_tuple( this_result, keys, QString(), Error() );
++ return boost::make_tuple( this_result, keys, QString(), Error() );
+ else
+ goto retry;
+ }
+@@ -119,7 +119,7 @@ retry:
+ break;
+ pats = pats.mid( chunkSize );
+ } while ( !pats.empty() );
+- return make_tuple( result, keys, QString(), Error() );
++ return boost::make_tuple( result, keys, QString(), Error() );
+ }
+
+ Error QGpgMEKeyListJob::start( const QStringList & patterns, bool secretOnly ) {
diff --git a/kde-apps/libkleo/libkleo-4.4.2017.04.ebuild b/kde-apps/libkleo/libkleo-4.4.2017.04.ebuild
index 3d99209b665b..36af6104b526 100644
--- a/kde-apps/libkleo/libkleo-4.4.2017.04.ebuild
+++ b/kde-apps/libkleo/libkleo-4.4.2017.04.ebuild
@@ -22,3 +22,5 @@ RDEPEND="${DEPEND}
KMSAVELIBS="true"
KMEXTRACTONLY="kleopatra/"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-6.3.patch" )