summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/print-manager
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-18.12.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 8df1de9d2124..c4757d56def0 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-18.08.3.tar.xz 238796 BLAKE2B f3fe67bb2a6b7f2e05b7ed8934ba491a829eff842fdd1f76af3cc376e679826e6ae1f332242d278215828b4842a0bf85b6e22d5b3ffb03d61f01c5f575cfa0d1 SHA512 0727f5e125ac2198276a92acfd881077647ab082b5edc9c4e5211f53dccd19e12b9b6934fd696424e029d5f7de373a194f9c302f587fb0c80af42526cd4a04ad
DIST print-manager-18.12.0.tar.xz 238876 BLAKE2B 9c80d1af88eb40745774291b5f75175e5efecbbfe8979848b660cf5b8ead44d3b1d01515258ff863434517ca4107712a2e0b47c522027e30a5989b71b477505f SHA512 66652e0644b75bbf16ffcc963fa272901b9130e96998e93c67d6c6914ffe28be581756b7e6b459d0477ed15a7a0ba9f7f6cd1c7938d4124a0443770619cc6541
+DIST print-manager-18.12.1.tar.xz 238868 BLAKE2B c12e90e660f7598f306a46b0aa800fdcad1e2f9a04bec229bcdf0a230b4ac079d5b5aa0a03aa6f8147100e53783a130b5a706a9cfe75a6f528b127163ab2d00b SHA512 e49adbb4118565f632e74e32c987ff2f735688e8091dc8eab8dbcabce0276b1360283e0e37729d13f6d1cfce5b27a78e3c4ac93b464adab07f92ac6b15244171
diff --git a/kde-apps/print-manager/print-manager-18.12.1.ebuild b/kde-apps/print-manager/print-manager-18.12.1.ebuild
new file mode 100644
index 000000000000..6d021308e98e
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-18.12.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}