summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/marble/marble-4.14.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/marble/marble-4.14.3.ebuild')
-rw-r--r--kde-apps/marble/marble-4.14.3.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/kde-apps/marble/marble-4.14.3.ebuild b/kde-apps/marble/marble-4.14.3.ebuild
new file mode 100644
index 000000000000..84dd3c45a3ae
--- /dev/null
+++ b/kde-apps/marble/marble-4.14.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit kde4-base python-single-r1
+
+DESCRIPTION="Generic geographical map widget"
+HOMEPAGE="http://marble.kde.org/"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug designer-plugin gps +kde phonon plasma python shapefile test zip"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# tests fail / segfault. Last checked for 4.9.0
+RESTRICT="test"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtdeclarative:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qtwebkit:4
+ designer-plugin? ( dev-qt/designer:4 )
+ gps? ( >=sci-geosciences/gpsd-2.95[qt4] )
+ kde? ( media-libs/phonon[qt4] )
+ phonon? ( media-libs/phonon[qt4] )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt4-4.4.4-r1[${PYTHON_USEDEP}]
+ kde? ( $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" ) )
+ )
+ shapefile? ( sci-libs/shapelib )
+ zip? ( dev-libs/quazip )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:4 )
+"
+# the qt dependencies are needed because with USE=-kde nothing is pulled in
+# by default... bugs 414165 & 429346
+
+REQUIRED_USE="
+ plasma? ( kde )
+ python? ( kde )
+"
+
+pkg_setup() {
+ kde4-base_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with designer-plugin DESIGNER_PLUGIN)
+ $(cmake-utils_use python EXPERIMENTAL_PYTHON_BINDINGS)
+ $(cmake-utils_use_with python PythonLibrary)
+ $(cmake-utils_use_with python PyQt4)
+ $(cmake-utils_use_with python SIP)
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use !kde QTONLY)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with shapefile libshp)
+ $(cmake-utils_use_with zip quazip)
+ -DBUILD_MARBLE_TESTS=OFF
+ -DWITH_liblocation=0
+ -DWITH_QextSerialPort=OFF
+ )
+
+ kde4-base_src_configure
+}
+
+src_test() {
+ if use kde; then
+ elog "Marble tests can only be run in the qt-only version"
+ else
+ local mycmakeargs=(
+ -DBUILD_MARBLE_TESTS=ON
+ )
+ kde4-base_src_test
+ fi
+}