summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:29:35 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 15:30:09 +0200
commitd9397ab8d48feb4b1360be614da35fa2faae44d9 (patch)
treecc33135aeeb6bb0faab58e8efc34329c14dff2b0 /kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild
parentdev-libs/libnl: Add USE='debug threads'. (diff)
downloadgentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.gz
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.tar.bz2
gentoo-d9397ab8d48feb4b1360be614da35fa2faae44d9.zip
kde-apps: Add KDE Applications 18.04.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild')
-rw-r--r--kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild b/kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild
new file mode 100644
index 000000000000..3c73db683d51
--- /dev/null
+++ b/kde-apps/libkcompactdisc/libkcompactdisc-18.04.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+inherit kde5
+
+DESCRIPTION="Library for playing & ripping CDs"
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ media-libs/phonon[qt5(+)]
+ alsa? ( media-libs/alsa-lib )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package alsa ALSA)
+ )
+ kde5_src_configure
+}