summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-29 17:02:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-29 17:52:21 +0100
commit0ebdc1a71a36933db4cb84d60b64f082fe374bd6 (patch)
treea97312e881351b722dc270e4a288d3d25d3f8227 /kde-apps/ktp-accounts-kcm
parentkde-apps/kopete: 21.11.90 version bump (diff)
downloadgentoo-0ebdc1a71a36933db4cb84d60b64f082fe374bd6.tar.gz
gentoo-0ebdc1a71a36933db4cb84d60b64f082fe374bd6.tar.bz2
gentoo-0ebdc1a71a36933db4cb84d60b64f082fe374bd6.zip
kde-apps/ktp-accounts-kcm: 21.11.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-21.11.90.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 327875aeee11..a62584a6f1ec 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1 +1,2 @@
DIST ktp-accounts-kcm-21.08.3.tar.xz 266276 BLAKE2B 0cfb3f651c88f281823eaf405080f178fdba2155526fbf4f4dba806363fae911609941fdcd256bf0fdf148789cd22857503ad0bc45181b60c6c127274d07441b SHA512 af0fc4d6c488495c7a3bc930dc5751a6bae5fd60f3423d35b30b9036b6289ec2c9aa0a5d8c7b5eb242ea93a64aa6daeae31760bcf321f6bc4d8ba017f78a2e7a
+DIST ktp-accounts-kcm-21.11.90.tar.xz 266348 BLAKE2B 81c2543c35b11a778e2eaf284f6b837d96e9bd0f1c961ce80b54379bad96fad13ea77015667afee41e82672852bb73718f82dbfa51a3c86d6c8a549a0ae25548 SHA512 28ae89ae4fb485d0b5f1159b6dd3040fd3b685347308620e26ff9d725db82bd2dcbe519b011dd4aa91548a9b8174c69e797935d797b722b442bb4443a3030357
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-21.11.90.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-21.11.90.ebuild
new file mode 100644
index 000000000000..648b4e78d2b2
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-21.11.90.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.88.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/KTp"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="experimental"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/kaccounts-integration-${PVCUT}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-libs/accounts-qt
+ net-libs/signond
+ >=net-libs/telepathy-qt-0.9.8
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-apps/kaccounts-providers-${PVCUT}:5
+ net-im/telepathy-connection-managers
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DISABLED_PROVIDERS=$(usex experimental)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+ ecm_pkg_postinst
+}