summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-14 17:13:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-15 07:36:14 +0200
commite19edabff80707de8772078358c8a9ca1169ca91 (patch)
treeb15a6cde4e36de6ddebe6a9e3d015312dc40dc8d /kde-apps/ktouch
parentkde5-functions.eclass: Update minimum deps (diff)
downloadgentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.gz
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.tar.bz2
gentoo-e19edabff80707de8772078358c8a9ca1169ca91.zip
kde-apps: Add KDE Applications 19.04.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktouch')
-rw-r--r--kde-apps/ktouch/Manifest1
-rw-r--r--kde-apps/ktouch/ktouch-19.04.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/ktouch/Manifest b/kde-apps/ktouch/Manifest
index f7f6a8383545..a6cf42e2f04a 100644
--- a/kde-apps/ktouch/Manifest
+++ b/kde-apps/ktouch/Manifest
@@ -1,2 +1,3 @@
DIST ktouch-18.12.3.tar.xz 5123496 BLAKE2B 1f1245c0045468bf10efb258147494c8eb0d71d91f4a29ee1f11f179f82f3f9c8658dc54ed9460712a5aa06ebd7d091b1bf5dffdb2e32ba5140aa6209ad76810 SHA512 1973b7d9e8ba61b4bfe9b23e53597ffe8eb4d00f4a57a3e2861a41b2b6c8bcf8204ad59d8d42d696e07a7d8c2b9cf7d3b4dbba8924fd2a9470d5b7524034a6cd
DIST ktouch-19.04.2.tar.xz 5135528 BLAKE2B adc51d9077375af05646dc83ca46f2c74b32fa7ec7082b7652da4b4cc640a8716b8a9e6a16abfed3e820cf0b287d0dad8bf11a4125e3a81cddcedb62fd0e1891 SHA512 18b53d966d280f7425948f0cafeddc0be118be3babe86537a18bd86b9398282693eecae9a1860f97c36255921d617821ed23a7fcc4e0da76730d51d8a869fb1c
+DIST ktouch-19.04.3.tar.xz 4947000 BLAKE2B 6148566525f9839dc93fd5365c426007568bda2bc0a76c86639ebdb27d62778d843b5cdfae65880f9f55114389add213077c15e87714e29d0a2644ed353034ca SHA512 499caa202f3e08d85240c0cb2b0099495d37c8c285701d5ac0834fd6a30a78b3988677577c5d21e24bf68a3ee22735b145f340794e5860fdb193c964ded49a34
diff --git a/kde-apps/ktouch/ktouch-19.04.3.ebuild b/kde-apps/ktouch/ktouch-19.04.3.ebuild
new file mode 100644
index 000000000000..e4bebb1ba1c6
--- /dev/null
+++ b/kde-apps/ktouch/ktouch-19.04.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Program that helps to learn and practice touch typing"
+HOMEPAGE="https://kde.org/applications/education/ktouch/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+# USE !X is broken, https://bugs.kde.org/show_bug.cgi?id=402902
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbfile
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwindowsystem)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kqtquickcharts)
+ $(add_qt_dep qtgraphicaleffects)
+ $(add_qt_dep qtquickcontrols)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCOMPILE_QML=OFF
+ )
+ kde5_src_configure
+}