summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/konsolekalendar
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 2272920d39ba..3442a181989c 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1 +1,2 @@
+DIST akonadi-calendar-tools-19.08.3.tar.xz 223564 BLAKE2B e0d9f01659a471307db2c7d8c0906297ec4a880cb0019414520b29a14eee68bf39b02d02dd4e5b3b03c3684022f675f30cdb6efb214adaca64dc27f5eec03c25 SHA512 4cc146da96f6a006749e4c3e0962155fc8bcd788d2ed39adbbe73f1d82bc4264349ce06a9b524ff4fb1a1675e0d66345e5bbad8044360b6fe28d9565672f3922
DIST akonadi-calendar-tools-19.12.3.tar.xz 223340 BLAKE2B b438f392618d919440fddf0ba5d48ab52a0c509507018d7f546b477aa83a34e8f86551c44998337ba2cfba8050d31cde9dc6f672b1a9ce6b558b292bb960d483 SHA512 eac1400ff742199908daf765b5cf14efd12b630a34e6fe0ac6bb17072b05902e746af5740a8e0db82a5ea7535a413140e9b6d4ea029f2abe684aff05098a8b39
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild
new file mode 100644
index 000000000000..f985c05e8357
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}