summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/kolourpaint
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-16.12.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
index f2495ef1b94c..67e32844b391 100644
--- a/kde-apps/kolourpaint/Manifest
+++ b/kde-apps/kolourpaint/Manifest
@@ -1,2 +1,3 @@
DIST kolourpaint-16.08.3.tar.xz 1175964 SHA256 db2fb22b4620519d733019e5c18c7dec2e71fd7695647beaa61e72982d0afb45 SHA512 a058d95c886726f3f7bbc21ba298041573afb047236c1438207c04c3d5e057725c764d168c37f3f8319bc2a02ccab42405584baa5c2ae7d03627604df9293875 WHIRLPOOL 4919d1a7678d2bdf398ba54bedef18dc989e006778071f84072e22440d31c05cc3d5ecceea6e67930b8a32bd40b7406954ce0aed464b8d68d131cbc1ca27c27d
DIST kolourpaint-16.12.0.tar.xz 879252 SHA256 8e5644951d3327329b45cec28519796a8866e2276d046278a523ce00456f5775 SHA512 d25950077d31c95c76277a8629022cd4fedb5581c8145fea1c94101058bd7e46f2d8c2a677c18bcaddf1ecb75ba952cfcf0385940057f491024af97871775695 WHIRLPOOL 0d9cf307e364bb4de48dbf365b0335e1aa48aa70f39cad03264c2bb8f6873420fa14c40c43cc8a662b578921325791783c982b90f54fe2ff433947f878a91d0e
+DIST kolourpaint-16.12.1.tar.xz 879284 SHA256 6162b62146d84377f3b24b70288b41798e8177e931f67836e9a15adcc620cf19 SHA512 6accffa13bf4247e0c5c567e0c86cc102cfceec1e0bbce02caeff566a902fb2b663f59d148bda2c601416ed8a49e61280900dce873b53cde5d3d52144c52f8fd WHIRLPOOL 0770a36873f8601d86aa3fbcaec1a44cddc2956a0fe01f4909ab4e6ca9d33d4d2fe876b55acaad83536d3aef25c356381e468121cb2c496486af5b5efff15228
diff --git a/kde-apps/kolourpaint/kolourpaint-16.12.1.ebuild b/kde-apps/kolourpaint/kolourpaint-16.12.1.ebuild
new file mode 100644
index 000000000000..90af05662dc1
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-16.12.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://www.kde.org/applications/graphics/kolourpaint/"
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+IUSE="scanner"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep libkexiv2)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ scanner? ( $(add_kdeapps_dep libksane) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scanner KF5Sane)
+ )
+
+ kde5_src_configure
+}