summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 22:22:38 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 22:30:42 +0100
commitd1fffc23873a520b7bf31cb50ba92cc49c711eb2 (patch)
tree177eab3137784318de920dd0f460111a37006cb7 /kde-apps/kio-extras
parentapp-office/libreoffice-l10n: Drop 6.1.2.1 (diff)
downloadgentoo-d1fffc23873a520b7bf31cb50ba92cc49c711eb2.tar.gz
gentoo-d1fffc23873a520b7bf31cb50ba92cc49c711eb2.tar.bz2
gentoo-d1fffc23873a520b7bf31cb50ba92cc49c711eb2.zip
kde-apps/kio-extras: Backport sftp level 18.11.80
Current stable version net-libs/libssh-0.8.4 does not bode well for kio-extras. Backport massive sftp fixes from Applications/18.12 branch (atm in depfreeze). Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kio-extras')
-rw-r--r--kde-apps/kio-extras/Manifest1
-rw-r--r--kde-apps/kio-extras/kio-extras-18.08.3-r1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-apps/kio-extras/Manifest b/kde-apps/kio-extras/Manifest
index c862cf703498..f7556bb1636c 100644
--- a/kde-apps/kio-extras/Manifest
+++ b/kde-apps/kio-extras/Manifest
@@ -1,2 +1,3 @@
DIST kio-extras-18.04.3.tar.xz 549840 BLAKE2B 7bb03f01fff6930d5b7bc4cdd01e960239d55ede4feb4eeb131db75515763cf924b288811cd99a5d89a79059f2cd5241e872b990799c758431f13f1440eef424 SHA512 49ab5ad8d74831a9ef1636e46abc76d66d3ef7d9e8f1ce793eb8d5c37f9e7ee4205c9643339f5c46657d4f537572e3f8a180ebace8599a1dfcbf8d27470b2f0b
+DIST kio-extras-18.08.3-sftp-18.11.80.patch.tar.xz 31376 BLAKE2B d4b44ec4c76309737a417d6bc930c360a0078f743cca96b1b12f164916e0596e0d29bf5d379e1896ffbea94962f2eb61d2b02b8f21000d3bfd75efe0fd55faa2 SHA512 15b43c2b73189db72e7d5b84eee5727ead49482d3d454591d5338b5dee876c751fad16fa76f3697b8ec2070d2bc2f89eec05e6de1ee402272d65aafe4464990c
DIST kio-extras-18.08.3.tar.xz 552044 BLAKE2B 22f6662a1c45ab80f217c9f2611f0ca33500897c31d8cb8d29949a00500301f1f72219baf17ab73011037e4e1c9cd85d5247692361dcf0ccbf5aed1d829ab922 SHA512 f79ab19abedd47baeffea4b1e99acc21611c9d435f0de14751594c97c373eaa493da07fd5d754b1f62f696e4f445b493861566845794d6d32e63e0354189d726
diff --git a/kde-apps/kio-extras/kio-extras-18.08.3-r1.ebuild b/kde-apps/kio-extras/kio-extras-18.08.3-r1.ebuild
new file mode 100644
index 000000000000..063449796af3
--- /dev/null
+++ b/kde-apps/kio-extras/kio-extras-18.08.3-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://cgit.kde.org/kio-extras.git"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${P}-sftp-18.11.80.patch.tar.xz"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="activities +man mtp openexr phonon samba +sftp taglib"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive 'bzip2,lzma')
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ activities? (
+ $(add_frameworks_dep kactivities)
+ $(add_qt_dep qtsql)
+ )
+ man? ( $(add_frameworks_dep khtml) )
+ mtp? ( >=media-libs/libmtp-1.1.16:= )
+ openexr? ( media-libs/openexr:= )
+ phonon? ( media-libs/phonon[qt5(+)] )
+ samba? ( net-fs/samba[client] )
+ sftp? ( net-libs/libssh:=[sftp] )
+ taglib? ( >=media-libs/taglib-1.11.1 )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kded)
+"
+DEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+ man? ( dev-util/gperf )
+"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+PATCHES=( "${WORKDIR}/${P}-sftp-18.11.80.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets=ON
+ $(cmake-utils_use_find_package activities KF5Activities)
+ $(cmake-utils_use_find_package man Gperf)
+ $(cmake-utils_use_find_package mtp Mtp)
+ $(cmake-utils_use_find_package openexr OpenEXR)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package samba Samba)
+ $(cmake-utils_use_find_package sftp libssh)
+ $(cmake-utils_use_find_package taglib Taglib)
+ )
+
+ kde5_src_configure
+}