summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/kig
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/kig-17.04.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
index b9c9576d5210..fcb694f7ca7b 100644
--- a/kde-apps/kig/Manifest
+++ b/kde-apps/kig/Manifest
@@ -1,2 +1,3 @@
DIST kig-16.12.3.tar.xz 1517896 SHA256 1c3e53df5f1a47d396d6072e5532699cf78127a81d104ff6c7ea6acb787fd43a SHA512 b7cda3ac927cff4e71efe0cbdfba3c60a8d1b0050f926e3791aee493419b4af05165c603a82d51f55c80ac05476d3c44d46932415fac3d575bf77a45ec965b47 WHIRLPOOL 60e93cfd73e2c6073a2bb3cbbc9a8138f75c00c256463dfd703ac9821b81e46393ceedc60376eb76ff76be006ffd45c265679e7f114c777d7c9ae0efbe2b96b7
DIST kig-17.04.0.tar.xz 3586468 SHA256 232133cb904b74f9406799ca1edaf0111816d42c459598c83c97925ededfa42f SHA512 1734aea67b10201b9324fe45d1ef04c1b0936fc68e1b301972d2617baee563f4603e3c0fe29f6cbe344d180fa56a8bfc86804aee5a3717326728fbe1aada0a5c WHIRLPOOL 642a5067f4ee4e8d9ed24844b10fefcde40a8c275783ea0b9c6f6107c9d11ac3757af11264917233bbecec295b184805ccd9032bc26234c3586ae62b649dd37a
+DIST kig-17.04.1.tar.xz 3586580 SHA256 129e67f3b203814502870549e87796c8576999a99062e6cf90808ee45fc3ade7 SHA512 c01552a36a7254eb49375e08b52e8cae366c74fc37c20574ae5c9e6ef1f13faa93b1b58ed8fc2f3705c0a4b55c73dc4bd46d2e41015aa158efc8012d3b7b05ba WHIRLPOOL 3a4c9fd8a8aae4a6c7c08e56b1802e01ed450b6beb5c2996c96462905432cb5880fbdaa1af8cbe9f3073d4961ddf12701baa09b68fcf5b090e01ba8222f39a30
diff --git a/kde-apps/kig/kig-17.04.1.ebuild b/kde-apps/kig/kig-17.04.1.ebuild
new file mode 100644
index 000000000000..c28dbdb68ab7
--- /dev/null
+++ b/kde-apps/kig/kig-17.04.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="https://www.kde.org/applications/education/kig https://edu.kde.org/kig"
+KEYWORDS="~amd64 ~x86"
+IUSE="geogebra scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ geogebra? ( $(add_qt_dep qtxmlpatterns) )
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep ktexteditor)
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package geogebra Qt5XmlPatterns)
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde5_src_configure
+}