summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/dolphin-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/dolphin-plugins')
-rw-r--r--kde-apps/dolphin-plugins/Manifest1
-rw-r--r--kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild35
-rw-r--r--kde-apps/dolphin-plugins/metadata.xml9
3 files changed, 45 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins/Manifest b/kde-apps/dolphin-plugins/Manifest
new file mode 100644
index 000000000000..c6fa30e3255f
--- /dev/null
+++ b/kde-apps/dolphin-plugins/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-4.14.3.tar.xz 58052 SHA256 b7f00e5ec037f8e8172de0fce0994958431157f0d89da21def9cdece7bc265ed SHA512 ffa624ef70de11575e56529a635044fa7f489198b5f12654c448aa370f8369296d251043f8d68453ad85e144c786df2ffae307be8e5265b63adfb4339887da24 WHIRLPOOL 09a717a565794e09d8124308e3ceebdd0f1df74a47f9ad6f4ad2558a99857b9f24e3ff4f44c62986e1482e3ea22fb063831765eb906e2964cf444ff6e040fdc5
diff --git a/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild b/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild
new file mode 100644
index 000000000000..76d73a848660
--- /dev/null
+++ b/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdeapps_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}
diff --git a/kde-apps/dolphin-plugins/metadata.xml b/kde-apps/dolphin-plugins/metadata.xml
new file mode 100644
index 000000000000..1df4bb871e62
--- /dev/null
+++ b/kde-apps/dolphin-plugins/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="bazaar">Enable support for the bazaar VCS</flag>
+ <flag name="mercurial">Enable support for the mercurial VCS</flag>
+ </use>
+</pkgmetadata>