summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-24 19:31:50 -0600
committerSam James <sam@gentoo.org>2023-09-25 02:59:03 +0100
commit6ce7c841bd1b7fa3e53e805f9200210fc548d29c (patch)
treeddc9c44bc4cf9748f3b2aaab6a4c9d1fdca08dd4 /gui-wm
parentmedia-libs/libuninameslist: add 20230916 (diff)
downloadgentoo-6ce7c841bd1b7fa3e53e805f9200210fc548d29c.tar.gz
gentoo-6ce7c841bd1b7fa3e53e805f9200210fc548d29c.tar.bz2
gentoo-6ce7c841bd1b7fa3e53e805f9200210fc548d29c.zip
gui-wm/dwl: fix nonexistent ${S}
and install desktop file (only for 0.4) Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/33043 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/dwl/dwl-0.4.ebuild7
-rw-r--r--gui-wm/dwl/dwl-9999-r1.ebuild4
-rw-r--r--gui-wm/dwl/dwl-9999.ebuild4
3 files changed, 12 insertions, 3 deletions
diff --git a/gui-wm/dwl/dwl-0.4.ebuild b/gui-wm/dwl/dwl-0.4.ebuild
index a80953766ba4..8a5fd16b0c32 100644
--- a/gui-wm/dwl/dwl-0.4.ebuild
+++ b/gui-wm/dwl/dwl-0.4.ebuild
@@ -5,6 +5,7 @@ EAPI=8
inherit savedconfig toolchain-funcs
+MY_P="${PN}-v${PV}"
WLROOTS_SLOT="0/16"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/djpohly/dwl"
@@ -22,7 +23,8 @@ if [[ ${PV} == *9999* ]]; then
;;
esac
else
- SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~x86"
fi
@@ -70,5 +72,8 @@ src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
dodoc README.md
+ insinto /usr/share/wayland-session
+ doins "${FILESDIR}/dwl.desktop"
+
save_config config.h
}
diff --git a/gui-wm/dwl/dwl-9999-r1.ebuild b/gui-wm/dwl/dwl-9999-r1.ebuild
index 9e7a7bdcfaf3..f093811e7e8a 100644
--- a/gui-wm/dwl/dwl-9999-r1.ebuild
+++ b/gui-wm/dwl/dwl-9999-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
inherit savedconfig toolchain-funcs
+MY_P="${PN}-v${PV}"
WLROOTS_SLOT="0/16"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/djpohly/dwl"
@@ -22,7 +23,8 @@ if [[ ${PV} == *9999* ]]; then
;;
esac
else
- SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~x86"
fi
diff --git a/gui-wm/dwl/dwl-9999.ebuild b/gui-wm/dwl/dwl-9999.ebuild
index a80953766ba4..6bb47768ea96 100644
--- a/gui-wm/dwl/dwl-9999.ebuild
+++ b/gui-wm/dwl/dwl-9999.ebuild
@@ -5,6 +5,7 @@ EAPI=8
inherit savedconfig toolchain-funcs
+MY_P="${PN}-v${PV}"
WLROOTS_SLOT="0/16"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/djpohly/dwl"
@@ -22,7 +23,8 @@ if [[ ${PV} == *9999* ]]; then
;;
esac
else
- SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/djpohly/${PN}/releases/download/v${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~x86"
fi