summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-11-09 22:52:04 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-11-10 14:55:38 +0200
commitc84612257129075d6022178955bed935a0d52fbd (patch)
tree689f0883a310141eb1eabfcf7d6014d2b867fb30 /gui-libs
parentmedia-sound/pavucontrol-qt: add version 1.2.0 (diff)
downloadgentoo-c84612257129075d6022178955bed935a0d52fbd.tar.gz
gentoo-c84612257129075d6022178955bed935a0d52fbd.tar.bz2
gentoo-c84612257129075d6022178955bed935a0d52fbd.zip
gui-libs/xdg-desktop-portal-lxqt: add version 0.3.0
Closes: https://bugs.gentoo.org/864777 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/Manifest1
-rw-r--r--gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/xdg-desktop-portal-lxqt/Manifest b/gui-libs/xdg-desktop-portal-lxqt/Manifest
index 72db1db31758..a2574ff5a171 100644
--- a/gui-libs/xdg-desktop-portal-lxqt/Manifest
+++ b/gui-libs/xdg-desktop-portal-lxqt/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-lxqt-0.2.0.tar.xz 15908 BLAKE2B c149395fa9f8993b20358f7958fe76bc355c42b3229f9287f045eaea456204e1faef28bfeaebcc85bf6ef45e11475adb5aed9af20d5e0a2befba62e22dc2e5b8 SHA512 4c1119340f4483eefe2ddb87ca6503d5213237007fef698765cf8c9e373339cc76ab6f66a0a6f58b605c1bb7e6320aeb815138ea72fad2a56e13cbd7a86bb4c6
+DIST xdg-desktop-portal-lxqt-0.3.0.tar.xz 16012 BLAKE2B a7b326e4ee7dd089b44e101c2be3625d6e81f229d7a6719ebb1743bc586f6c52044792e7eec10ce6821f60119f4a891cc640ab44f494ba4322cac03dcefb7b00 SHA512 13ffa6fc53eec53805b23a533bcccbe786482c1d587da0ab055ba4275bc46bbb545073749899f13164b740348b8736860f364710cc1b5d980352288f6ffc12d7
diff --git a/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.3.0.ebuild b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.3.0.ebuild
new file mode 100644
index 000000000000..cad3736b4e64
--- /dev/null
+++ b/gui-libs/xdg-desktop-portal-lxqt/xdg-desktop-portal-lxqt-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Qt/KF5/libfm-qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.12.0"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/kwindowsystem:5
+ >=x11-libs/libfm-qt-1.2:=
+"
+RDEPEND="${DEPEND}
+ sys-apps/xdg-desktop-portal
+"