summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-05-18 21:00:49 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-18 21:00:49 +0200
commit855c0465f04b4148c69495fee24a64c70859bf11 (patch)
treee985ee2ddf39536c9a7bfe97cb67a7c4c26e0d39 /gui-libs
parentx11-drivers/nvidia-drivers: drop 465.24.02 (diff)
downloadgentoo-855c0465f04b4148c69495fee24a64c70859bf11.tar.gz
gentoo-855c0465f04b4148c69495fee24a64c70859bf11.tar.bz2
gentoo-855c0465f04b4148c69495fee24a64c70859bf11.zip
gui-libs/egl-wayland: add 1.1.7
Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 8789cb0974d5..c5ab0422ed1b 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1 +1,2 @@
DIST egl-wayland-1.1.6.tar.gz 48674 BLAKE2B 66f58d4b841ebaaec6c0711e0dae0b3c774a7b0206f9cfd4d9e94a2c05688d563fddbbf9a60247980df00c3c493147e292bc536e2eb56de962f3b34c6215e026 SHA512 81fd3be3f49ad012efd31189d85666e869653f1f4004de4103f4ad13b7fda036cef432d1e30e33664ae423092dc1b86cfd2773d6542bb09d7a74720ba14e0fa4
+DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild
new file mode 100644
index 000000000000..01dea054a2c3
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic meson
+
+DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/wayland
+ !x11-drivers/nvidia-drivers[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_configure() {
+ # EGLStream is not intended for X11, always build without (bug #777558)
+ append-cppflags -DEGL_NO_X11
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To use EGLStream with x11-drivers/nvidia-drivers, it is necessary to"
+ elog "load the nvidia-drm module with experimental nvidia-drm.modeset=1."
+ elog
+ elog "Can be accomplished by:"
+ elog " echo 'options nvidia-drm modeset=1' > ${EROOT}/etc/modprobe.d/nvidia-drm.conf"
+ elog "...then reloading the module."
+ elog
+ elog "Note that EGLStream requires support from the wayland compositor and"
+ elog "is not currently supported by many popular options such as gui-wm/sway."
+ fi
+
+ if has_version "<x11-drivers/nvidia-drivers-391"; then
+ ewarn "<=nvidia-drivers-390.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}