summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-31 20:25:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-31 20:25:57 -0500
commit767f7bb75242de40719d3c8fee388b7d135a4394 (patch)
treec4d67ec43f1e16afcc63516687289183fa6bcda4 /gui-libs
parentapp-text/vgrep: bump to v2.5.5 (diff)
downloadgentoo-767f7bb75242de40719d3c8fee388b7d135a4394.tar.gz
gentoo-767f7bb75242de40719d3c8fee388b7d135a4394.tar.bz2
gentoo-767f7bb75242de40719d3c8fee388b7d135a4394.zip
gui-libs/wlroots: add vulkan flags
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/metadata.xml1
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild10
2 files changed, 9 insertions, 2 deletions
diff --git a/gui-libs/wlroots/metadata.xml b/gui-libs/wlroots/metadata.xml
index d6db63eaef4f..1c86adb5d1fc 100644
--- a/gui-libs/wlroots/metadata.xml
+++ b/gui-libs/wlroots/metadata.xml
@@ -21,6 +21,7 @@
wlroots is developed under the direction of the <pkg>gui-wm/sway</pkg> project.
</longdescription>
<use>
+ <flag name="vulkan">Enable support for the vulkan backend renderer</flag>
<flag name="x11-backend">Enable support for handling input/output devices through <pkg>x11-libs/libxcb</pkg></flag>
<flag name="X">Enable support for X11 applications (XWayland)</flag>
</use>
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 2a1240692e30..1b918a2014a5 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -19,7 +19,7 @@ else
fi
LICENSE="MIT"
-IUSE="x11-backend X"
+IUSE="vulkan x11-backend X"
DEPEND="
>=dev-libs/libinput-1.14.0:0=
@@ -28,6 +28,11 @@ DEPEND="
media-libs/mesa[egl(+),gles2,gbm(+)]
sys-auth/seatd:=
virtual/libudev
+ vulkan? (
+ dev-util/glslang:0=
+ dev-util/vulkan-headers:0=
+ media-libs/vulkan-loader:0=
+ )
x11-libs/libdrm
x11-libs/libxkbcommon
x11-libs/pixman
@@ -54,9 +59,10 @@ src_configure() {
"-Dxcb-errors=disabled"
"-Dexamples=false"
"-Dwerror=false"
- "-Drenderers=gles2"
+ -Drenderes=$(usex vulkan 'gles2,vulkan' gles2)
-Dxwayland=$(usex X enabled disabled)
)
+# "-Drenderers=gles2"
meson_src_configure
}