summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 11:08:20 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 11:33:02 -0400
commit9786a9937a11c06ac6674910d30d08457682c42e (patch)
tree84f67d77ba38ea001eaa01c0535c95918aec465f /gui-libs/wpebackend-fdo
parentgui-libs/libwpe: Version bump to 1.14.0 (diff)
downloadgentoo-9786a9937a11c06ac6674910d30d08457682c42e.tar.gz
gentoo-9786a9937a11c06ac6674910d30d08457682c42e.tar.bz2
gentoo-9786a9937a11c06ac6674910d30d08457682c42e.zip
gui-libs/wpebackend-fdo: Version bump to 1.14.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/wpebackend-fdo')
-rw-r--r--gui-libs/wpebackend-fdo/Manifest1
-rw-r--r--gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-libs/wpebackend-fdo/Manifest b/gui-libs/wpebackend-fdo/Manifest
index 823de1c38e43..f5f83e73c107 100644
--- a/gui-libs/wpebackend-fdo/Manifest
+++ b/gui-libs/wpebackend-fdo/Manifest
@@ -1,2 +1,3 @@
DIST wpebackend-fdo-1.12.0.tar.xz 43080 BLAKE2B 0ef0e537d430b60841732e9b350d46b44317c2ee9833d6f382cc792a7aaf6e93b5eb782c4913c6bd7af5e30a08cac348430d4d383bce247415babf48f1f4322f SHA512 856885394872ad3f205b600caecbae48ae0c51185a8e19e66add93222e49bb1b060cdc77f5c9269d43509a0b85af0b5642c27f951d1c9836d8616aa51a9180a5
DIST wpebackend-fdo-1.12.1.tar.xz 43148 BLAKE2B 3d666cdcd68c3b9356ec58020502bf4d61c0d8651b9dcc646f50ba63aa336e475a47627712678e4a192e0502cd86ea030613199503b056efe4c7afa3a49e0490 SHA512 0464ab4eb634390591b8cc09bc3db6a3a816c68aef6f9140012230e8dba9550e44bdc4f9008ea3fecfcc5f441306d6c4d91e6f693398179ee8bf7516dd58875b
+DIST wpebackend-fdo-1.14.0.tar.xz 43068 BLAKE2B e5b06e7313a0122578fd668cb17a0f28e8f67ba4831b80616979ebedf15ee4fde94f610b5c7e4831ce90c51e11573ff8fc8f4970237230f5d3184b8aead21ce6 SHA512 9eda873adda854e1e498236215b7e240076caca52adca4f60277fb26db8ae9e6436b27a9b25ebf95612835acad82b764ccd21d8ae997e8802665dd79251083d6
diff --git a/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.0.ebuild b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.0.ebuild
new file mode 100644
index 000000000000..0b98d16fc95c
--- /dev/null
+++ b/gui-libs/wpebackend-fdo/wpebackend-fdo-1.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="WPE backend designed for Linux desktop systems"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libepoxy[egl]
+ dev-libs/glib:2
+ >=dev-libs/wayland-1.10
+ >=gui-libs/libwpe-1.6:1.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbuild_docs=false # hotdoc not packaged
+ )
+
+ meson_src_configure
+}