summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-06-01 19:13:51 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-06-01 19:13:51 -0500
commit3483d7c3de4048ef4acdac4546b2be43cee5eccd (patch)
tree4357ada963030b59ae010fb4ade867c59f400382 /gui-apps
parentdev-vcs/git: add 2.41.0 (diff)
downloadgentoo-3483d7c3de4048ef4acdac4546b2be43cee5eccd.tar.gz
gentoo-3483d7c3de4048ef4acdac4546b2be43cee5eccd.tar.bz2
gentoo-3483d7c3de4048ef4acdac4546b2be43cee5eccd.zip
gui-apps/mako: add 1.8.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/mako/Manifest1
-rw-r--r--gui-apps/mako/mako-1.8.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
index 43829ed23d19..b904781a33e2 100644
--- a/gui-apps/mako/Manifest
+++ b/gui-apps/mako/Manifest
@@ -1 +1,2 @@
DIST mako-1.7.1.tar.gz 62511 BLAKE2B 2556e0be7181999624cfa09898649c61a18691559c9693660db0ff79966bead32c327f217ecc66110526f5dfe02154083334ae8fa82f110869a59f29fa9bc5ae SHA512 a6066327fe6f19eb2717773dca0ea52eb1ad5c402780d12aa07b184f8a11c27a7c77e5c037cd9ff618bce35caa740da1af6ad3b41509e80e75ab5c0efb032588
+DIST mako-1.8.0.tar.gz 63143 BLAKE2B da39c1d2a1748649432d2760831cee7c9b135114b8e36c48a87900d9a3610fc5103c15f2ed511344d84a3142aa76ddd3680177318d0e096ad0574952632dc0b7 SHA512 d187c00296f3c3d4fb2c5964a95e1ac6ab74deb7dc27633d8e8301d60d90e4dc92b0ee66953670c42a3c08160536a4126ee747214c4ea05a30a80fd5e2004ad0
diff --git a/gui-apps/mako/mako-1.8.0.ebuild b/gui-apps/mako/mako-1.8.0.ebuild
new file mode 100644
index 000000000000..13a9eb711c00
--- /dev/null
+++ b/gui-apps/mako/mako-1.8.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gtk+:3
+ x11-libs/gdk-pixbuf
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/wayland-protocols-1.21
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ -Dzsh-completions=true
+ -Dfish-completions=true
+ -Dbash-completions=true
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ systemd_douserunit contrib/systemd/mako.service
+}