summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-17 22:15:37 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-05 21:55:35 -0400
commitd9417ccd32203674221f957f07db7108f7ffd2e2 (patch)
tree51450b85f35af3c821313dbc7bc730e1e16d28f0 /gui-apps/lavalauncher
parentgui-wm/hikari: new wayland window manager (diff)
downloadgentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.tar.gz
gentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.tar.bz2
gentoo-d9417ccd32203674221f957f07db7108f7ffd2e2.zip
gui-apps/lavalauncher: new wayland application launcher
Closes: https://bugs.gentoo.org/723524 Minimalistic and simple launcher for Wayland. It serves a single purpose: Letting the user execute shell commands by clicking on icons on a dynamically sized bar, placed at one of the screen edges. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15861 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps/lavalauncher')
-rw-r--r--gui-apps/lavalauncher/Manifest1
-rw-r--r--gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch27
-rw-r--r--gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch12
-rw-r--r--gui-apps/lavalauncher/lavalauncher-1.7.1.ebuild49
-rw-r--r--gui-apps/lavalauncher/lavalauncher-9999.ebuild49
-rw-r--r--gui-apps/lavalauncher/metadata.xml22
6 files changed, 160 insertions, 0 deletions
diff --git a/gui-apps/lavalauncher/Manifest b/gui-apps/lavalauncher/Manifest
new file mode 100644
index 000000000000..5980796af06a
--- /dev/null
+++ b/gui-apps/lavalauncher/Manifest
@@ -0,0 +1 @@
+DIST lavalauncher-1.7.1.tar.gz 82550 BLAKE2B 043fd8a8fb977f89414b4c9eb5a29ae05cea6374ea7bdbf595a3c75eeee4c5273b2d84cd437a451b0a4fec4139e31dec6c520e4a0af745c06b438b1290c114b4 SHA512 e1848d29275a444aef2b85bd6b27ae056cfc76c337695da2f7061ca3d73f510b797f84663a5705d59615a2a4ea0be64388ce1d4d622379f86cfc23d82f2e51d8
diff --git a/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch b/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch
new file mode 100644
index 000000000000..612548e17a78
--- /dev/null
+++ b/gui-apps/lavalauncher/files/lavalauncher-1.7.1-optional-man.patch
@@ -0,0 +1,27 @@
+diff --git a/meson.build b/meson.build
+index 029f711..50beccd 100644
+--- a/meson.build
++++ b/meson.build
+@@ -6,7 +6,6 @@ project(
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=3',
+- 'werror=true',
+ ]
+ )
+
+@@ -61,6 +60,7 @@ scdoc = dependency(
+ 'scdoc',
+ version: '>=1.9.2',
+ native: true,
++ required: get_option('man-page'),
+ )
+ if scdoc.found()
+ scdoc_prog = find_program(scdoc.get_pkgconfig_variable('scdoc'), native: true)
+diff --git a/meson_options.txt b/meson_options.txt
+new file mode 100644
+index 0000000..2e41905
+--- /dev/null
++++ b/meson_options.txt
+@@ -0,0 +1 @@
++option('man-page', type: 'feature', value: 'auto', description: 'Generate and install man pages')
diff --git a/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch b/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch
new file mode 100644
index 000000000000..3be85ab800c6
--- /dev/null
+++ b/gui-apps/lavalauncher/files/lavalauncher-remove-werror.patch
@@ -0,0 +1,12 @@
+diff --git a/meson.build b/meson.build
+index 317eeec..560421d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -6,7 +6,6 @@ project(
+ default_options: [
+ 'c_std=c11',
+ 'warning_level=3',
+- 'werror=true',
+ ]
+ )
+
diff --git a/gui-apps/lavalauncher/lavalauncher-1.7.1.ebuild b/gui-apps/lavalauncher/lavalauncher-1.7.1.ebuild
new file mode 100644
index 000000000000..09c59864508c
--- /dev/null
+++ b/gui-apps/lavalauncher/lavalauncher-1.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="simple launcher for wayland"
+HOMEPAGE="https://git.sr.ht/~leon_plickat/lavalauncher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~leon_plickat/lavalauncher"
+else
+ SRC_URI="https://git.sr.ht/~leon_plickat/lavalauncher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="man"
+
+PATCHES=(
+ "${FILESDIR}/${P}-optional-man.patch"
+)
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-page)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/lavalauncher/lavalauncher-9999.ebuild b/gui-apps/lavalauncher/lavalauncher-9999.ebuild
new file mode 100644
index 000000000000..22da8a44a0ec
--- /dev/null
+++ b/gui-apps/lavalauncher/lavalauncher-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="simple launcher for wayland"
+HOMEPAGE="https://git.sr.ht/~leon_plickat/lavalauncher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~leon_plickat/lavalauncher"
+else
+ SRC_URI="https://git.sr.ht/~leon_plickat/lavalauncher/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="man"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+PATCHES=(
+ "${FILESDIR}/lavalauncher-remove-werror.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-page)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/lavalauncher/metadata.xml b/gui-apps/lavalauncher/metadata.xml
new file mode 100644
index 000000000000..3b6117c8b1a8
--- /dev/null
+++ b/gui-apps/lavalauncher/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Minimalistic and simple launcher for Wayland.
+ It serves a single purpose: Letting the user
+ execute shell commands by clicking on icons on
+ a dynamically sized bar, placed at one of the
+ screen edges.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+</pkgmetadata>