summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-base/gnustep-updater
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-base/gnustep-updater')
-rw-r--r--gnustep-base/gnustep-updater/Manifest2
-rw-r--r--gnustep-base/gnustep-updater/gnustep-updater-0.2.ebuild24
-rw-r--r--gnustep-base/gnustep-updater/gnustep-updater-0.3.ebuild24
-rw-r--r--gnustep-base/gnustep-updater/metadata.xml7
4 files changed, 57 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-updater/Manifest b/gnustep-base/gnustep-updater/Manifest
new file mode 100644
index 000000000000..1b368a780ca2
--- /dev/null
+++ b/gnustep-base/gnustep-updater/Manifest
@@ -0,0 +1,2 @@
+DIST gnustep-updater-0.2.tar.bz2 3523 SHA256 9bd5cb66ff8a4365e365d630691a79349b642e3af720fdaeef5ed25589ca7953
+DIST gnustep-updater-0.3.tar.bz2 3685 SHA256 001fcd21cf76f511af3cc734400dee009cfc61a9cc95e233ed9cdc6a42a4041a SHA512 079b51c54a7860c4eea65ffc63172ea69e88de4a34f2ca0d0c5ad3a1342ea37ee69edb107f287f04d33c3ee03658edd5386d1323f47e9bc201bc70d68d0c9c4b WHIRLPOOL 7bc5df801d94fbee8cb4a644c93157f5ab047cb2d417f2dd77afbb67129242f40d5d94ca77a93eb9b0d1254814a0095b8691b7663cbfd196ea7b8721fb40ab15
diff --git a/gnustep-base/gnustep-updater/gnustep-updater-0.2.ebuild b/gnustep-base/gnustep-updater/gnustep-updater-0.2.ebuild
new file mode 100644
index 000000000000..22d3c674e6e4
--- /dev/null
+++ b/gnustep-base/gnustep-updater/gnustep-updater-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Helper tool to upgrade Gentoo GNUstep installations"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND="${DEPEND}
+ app-misc/pax-utils
+ >=gnustep-base/gnustep-make-2.6.0"
+
+src_install() {
+ dosbin gnustep-updater
+ doman gnustep-updater.1
+}
diff --git a/gnustep-base/gnustep-updater/gnustep-updater-0.3.ebuild b/gnustep-base/gnustep-updater/gnustep-updater-0.3.ebuild
new file mode 100644
index 000000000000..538c3cb0d795
--- /dev/null
+++ b/gnustep-base/gnustep-updater/gnustep-updater-0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Helper tool to upgrade Gentoo GNUstep installations"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-shells/bash"
+RDEPEND="${DEPEND}
+ app-misc/pax-utils
+ >=gnustep-base/gnustep-make-2.6.0"
+
+src_install() {
+ dosbin gnustep-updater
+ doman gnustep-updater.1
+}
diff --git a/gnustep-base/gnustep-updater/metadata.xml b/gnustep-base/gnustep-updater/metadata.xml
new file mode 100644
index 000000000000..5dad78fef623
--- /dev/null
+++ b/gnustep-base/gnustep-updater/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>Helper tool to upgrade Gentoo GNUstep installations, after
+ the switch to FHS layout for example</longdescription>
+</pkgmetadata>