summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/pictureframe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/pictureframe')
-rw-r--r--gnustep-apps/pictureframe/Manifest3
-rw-r--r--gnustep-apps/pictureframe/metadata.xml6
-rw-r--r--gnustep-apps/pictureframe/pictureframe-1.0.0.ebuild21
-rw-r--r--gnustep-apps/pictureframe/pictureframe-1.1.2.ebuild22
-rw-r--r--gnustep-apps/pictureframe/pictureframe-1.1.3.ebuild23
5 files changed, 75 insertions, 0 deletions
diff --git a/gnustep-apps/pictureframe/Manifest b/gnustep-apps/pictureframe/Manifest
new file mode 100644
index 000000000000..aa788f4f9556
--- /dev/null
+++ b/gnustep-apps/pictureframe/Manifest
@@ -0,0 +1,3 @@
+DIST PictureFrame-1.0.0.tar.gz 323256 RMD160 fa8d91c980c10ac79f2d0855c617ef0687bd90e5 SHA1 b8ace710f777b513b48d95fbec36ab856726d11c SHA256 72544560336bd9b2900133fb563096b622ee08050d1c09b998be3a215ecad7e5
+DIST PictureFrame-1.1.2.tar.gz 343556 RMD160 d15ab0f27c4022942dd598fdac5e07031c091591 SHA1 657ff28b7e2930971ce0917a6e46a2eef79f86f1 SHA256 8f84d9cbeb5ec12201b2b382e7a99ec33cab669bf574562146824a2f5f89ffcf
+DIST PictureFrame-1.1.3.tar.gz 343981 RMD160 8c32a51aeda07e08a32af06fe99b8773e3858a62 SHA1 1a95d6b53e3509c458a0015913fc2ca2b0efd3fd SHA256 5fb89e50df5dee611bc15629b1d613f24a3b52b8e655b672d383067497c8ed1e
diff --git a/gnustep-apps/pictureframe/metadata.xml b/gnustep-apps/pictureframe/metadata.xml
new file mode 100644
index 000000000000..0bb3feab5ae9
--- /dev/null
+++ b/gnustep-apps/pictureframe/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>digital picture frame software</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/pictureframe/pictureframe-1.0.0.ebuild b/gnustep-apps/pictureframe/pictureframe-1.0.0.ebuild
new file mode 100644
index 000000000000..5f7ff5a6d788
--- /dev/null
+++ b/gnustep-apps/pictureframe/pictureframe-1.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+MY_PN=PictureFrame
+DESCRIPTION="digital picture frame software"
+HOMEPAGE="http://www.nongnu.org/gap/pictureframe/index.html"
+SRC_URI="http://ftp.gnustep.org/pub/gnustep/contrib/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc PICTURE_FRAMES README
+}
diff --git a/gnustep-apps/pictureframe/pictureframe-1.1.2.ebuild b/gnustep-apps/pictureframe/pictureframe-1.1.2.ebuild
new file mode 100644
index 000000000000..223ce59aff8a
--- /dev/null
+++ b/gnustep-apps/pictureframe/pictureframe-1.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+MY_PN=PictureFrame
+DESCRIPTION="digital picture frame software"
+HOMEPAGE="http://www.nongnu.org/gap/pictureframe/index.html"
+SRC_URI="http://ftp.gnustep.org/pub/gnustep/contrib/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc PICTURE_FRAMES README
+}
diff --git a/gnustep-apps/pictureframe/pictureframe-1.1.3.ebuild b/gnustep-apps/pictureframe/pictureframe-1.1.3.ebuild
new file mode 100644
index 000000000000..c5a0863e5c2a
--- /dev/null
+++ b/gnustep-apps/pictureframe/pictureframe-1.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+MY_PN=PictureFrame
+DESCRIPTION="digital picture frame software"
+HOMEPAGE="http://www.nongnu.org/gap/pictureframe/index.html"
+SRC_URI="http://ftp.gnustep.org/pub/gnustep/contrib/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_install() {
+ gnustep-base_src_install
+ dodoc PICTURE_FRAMES README
+}