summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-28 08:22:38 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-28 08:31:06 -0700
commit61932f9fb24ef5c28b6b3714b9d62efd7932c831 (patch)
treee331c82b4ee17ff8d38f1e646a4f4a4373f3ebc6 /gnome-extra
parentgnome-extra/gnome-software: Version bump to 42.1 (diff)
downloadgentoo-61932f9fb24ef5c28b6b3714b9d62efd7932c831.tar.gz
gentoo-61932f9fb24ef5c28b6b3714b9d62efd7932c831.tar.bz2
gentoo-61932f9fb24ef5c28b6b3714b9d62efd7932c831.zip
gnome-extra/zenity: Version bump to 3.42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.42.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index b84aaccea570..bf8d1374e08f 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,2 +1,3 @@
DIST zenity-3.41.0.tar.xz 3093244 BLAKE2B 582a2e935331120c47ef997d100c28943694a9b8b35c70673c8dca6e129bf39d9a32c92cf6504602513ad6eb223239be584c56ef44fe609f8af320f27713ca4a SHA512 b198ae68fda77f74c9f6deba683759612067c4ee28551a667c96500296db89313f3f2330fcaa53b6e4840ee3367d438e766be8ba7c006952872aebe93684b307
DIST zenity-3.42.0.tar.xz 3091448 BLAKE2B 0a2f595164f5f9e8ebfa800855b15b116ab453435a2a1287ba7c85698d391dfecce3c8e2f8237ce73403ce7187a340ed5353e4ff283b05a0ecdcdc55f950f526 SHA512 a17b7ee46f480ca3e3804d301d1a499393aa10aee62d96d5087841ca8951a46f2b51e8355dd63b81b078efd69a11d57ed4fa187052d98880b12e56fd11e53ddb
+DIST zenity-3.42.1.tar.xz 3091752 BLAKE2B 7364ce9175efb7d4954956c1c2bd347ffd8060f02be3c21ec65525ee84e082eeffd8af3cb72b3f051f401a9ff90595c0a015223efcd96b6069e9bc3d276de16e SHA512 a8239e7dde351f3d3f75a59c95588f672c69333d4a53d50465d05fb73e61d1bbff6aca89acffc35a8d6802f465048ad2cbd7421bc3e3200a5a393ee3c9319106
diff --git a/gnome-extra/zenity/zenity-3.42.1.ebuild b/gnome-extra/zenity/zenity-3.42.1.ebuild
new file mode 100644
index 000000000000..e81d45b27ae7
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.42.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3[X]
+ >=dev-libs/glib-2.43.4:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4 )
+ x11-libs/libX11
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use libnotify)
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}