summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-09-21 21:28:21 +0300
committerMart Raudsepp <leio@gentoo.org>2017-09-21 21:28:21 +0300
commit5e7df26d472f0c94a6d8da608003cb9da6ebc72b (patch)
tree023171d7f42339e99e779bf97efeea19cf9f9025 /gnome-extra
parentdev-db/postgresql: Bump to 10_rc1 (diff)
downloadgentoo-5e7df26d472f0c94a6d8da608003cb9da6ebc72b.tar.gz
gentoo-5e7df26d472f0c94a6d8da608003cb9da6ebc72b.tar.bz2
gentoo-5e7df26d472f0c94a6d8da608003cb9da6ebc72b.zip
gnome-extra/gnome-shell-extensions-topicons-plus: bump to v21 for bug fixes and GNOME 3.26 compat
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
index 3e115eb89f0d..51045238a0ae 100644
--- a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extensions-topicons-plus-20.tar.gz 6173720 SHA256 02ffe087b390b277ce3245b3db675977dad0ed5b6503d719e6e868d8a3082825 SHA512 89feaf4a42f1785c7667ba451efddce2322599c5441bfe66c8bcc72fa3c07bbc2535e34db5383ab9c5b38a61f83ec6ef245473f2c269708e4042684f2d7a07bc WHIRLPOOL 0ccba7837700964e730ab07c8fdac5795b08aab884fa0feab56789e0a5b8166ed864836a383baa01be86c49969a409c4d3b92f2a6653eaeb0387114352e245ca
+DIST gnome-shell-extensions-topicons-plus-21.tar.gz 2756641 SHA256 92c0865dff0bba89b64fa8a7808a29294bf6904430336c7cb13f51b823f74a13 SHA512 f85db46f20c24f0b11ce2c79c0548b88262faf059d674073e328917dc8497de0e07ccd6f3613f45aa9e49109468d78293f3a8f0f4fea5a24a7c5254666cda5df WHIRLPOOL 56c9933775ba9d10ee6bb383cf60ca76430ee97a6b22f238ef4b64892aecb61a8e523cd3e65ac6857a7e5d32c54d28bfcb4f8da1a6eca1df23e65afe8233ef6f
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
new file mode 100644
index 000000000000..7639cc3ca8ae
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ # Assuming it needs only compiled gettext catalogs at runtime
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/locale"/*/LC_MESSAGES/*.po || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}