summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-06 23:32:17 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-06 23:54:54 +0200
commit59be07ff412ca0e42dc93c1b23d8affc4cb89d09 (patch)
treebb8cf35ad1217e6d5cd80d40688128e6e3c88ecd /gnome-extra
parentapp-misc/yq: version bump to 2.7.1 (diff)
downloadgentoo-59be07ff412ca0e42dc93c1b23d8affc4cb89d09.tar.gz
gentoo-59be07ff412ca0e42dc93c1b23d8affc4cb89d09.tar.bz2
gentoo-59be07ff412ca0e42dc93c1b23d8affc4cb89d09.zip
gnome-extra/gnome-contacts: bump to 3.26.1
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-contacts/Manifest1
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.26.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
index d2176eb05656..92d9ed9f76cc 100644
--- a/gnome-extra/gnome-contacts/Manifest
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -1 +1,2 @@
DIST gnome-contacts-3.22.1.tar.xz 788820 BLAKE2B 8f620334dd380e8cb690f7b71d3a99a921f5814ab230690a60be6022150db7a6a0f74e426e72d8d027eb5280e1b6bfd04fa7b0b030519bb19e4718ca0c9f2120 SHA512 d93ed6c65ffdabe1925cc795b88ff374fe69e03fcd36af7c2fc67a5236b90ab6af4bd269b6fc3b344fcd6b4688d866628b8b090bb62de95f8bd0c2e40c26a107
+DIST gnome-contacts-3.26.1.tar.xz 974588 BLAKE2B da989125408702099ecd1afaad6c06ab1cbeda2309bc7b207be671c833792a325bbbba0ebc6561f960d2c524ebd51743a60d5b792a0c2b8126318d38a6d801aa SHA512 1ba445efd71dbc77213d75011b0abcffcf6fe534cba14cf8ca92890e8dfb7b44d9565399200aa7aa03862cf08be60289b78501a1807a760bb1e68f0fe46c4685
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.26.1.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.26.1.ebuild
new file mode 100644
index 000000000000..0496d35861d3
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.26.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.6:=
+ dev-libs/folks[vala(+)]
+ gnome-base/gnome-desktop:3=[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=dev-libs/folks-0.11.4:=[eds,telepathy]
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ media-libs/clutter:1.0
+ media-libs/clutter-gtk:1.0
+ media-libs/libchamplain:0.12
+ net-libs/gnome-online-accounts:=
+ >=net-libs/telepathy-glib-0.22.0
+ >=sci-geosciences/geocode-glib-3.15.3
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.20.0:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Regenerate the pre-generated C sources, bug #471628
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-man-pages \
+ $(use_with v4l cheese)
+}