summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-22 15:00:07 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-22 15:06:59 +0300
commit847e7de7a489e9a9e54ab63c0f1b36fc9c3ed03a (patch)
tree28037f58e56cc9b3fbe786d6f0b888828517db61 /gnome-extra/gnome-weather
parentnet-irc/polari: bump to 3.36.3 (diff)
downloadgentoo-847e7de7a489e9a9e54ab63c0f1b36fc9c3ed03a.tar.gz
gentoo-847e7de7a489e9a9e54ab63c0f1b36fc9c3ed03a.tar.bz2
gentoo-847e7de7a489e9a9e54ab63c0f1b36fc9c3ed03a.zip
gnome-extra/gnome-weather: bump to 3.36.1
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 45a2a2f09216..ffc6a57578d5 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-3.34.2.tar.xz 5957924 BLAKE2B d6257fb7654862f5fbd308bc202ce8b8f98a0b6baa5a150a1729962fa05812a93cd19f9462d83fec3d076b896be1d8166e360811c84bc3ab4f13b212b48884e5 SHA512 9e9ebbdf795b175f7640ad684da7642a3e6a07da4d95c520a8673f0001aac119c5ebe22737d254a75b878f503910265fa0fdf05b1c219063f6b4dfc6bc8d1633
+DIST gnome-weather-3.36.1.tar.xz 5959192 BLAKE2B f0745506ffd2b72a1a5fe0783fe04c563691840fdf2150e7850cd331ba2027b1d1fcbbb4565830d05c7e39e62a2c94e4c87443ce5786cc70f3ebabcc66e97eec SHA512 c3d4b0e7258c0bfbc1ab2b5695d601fe79326e1bed856734edc309c612f1cc0adc9cfd6b4afb4ad3069b864c807ca0b21a60f89feba68f1dacac58d0fd2221be
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild
new file mode 100644
index 000000000000..fa585992b10f
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-3.36.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-3.28:=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}