summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-08-30 12:00:34 +0200
committerPacho Ramos <pacho@gentoo.org>2020-08-30 12:01:08 +0200
commit3b7d3b75913425bdc7c5782d988e4dd4f1f67fe8 (patch)
tree35ba79039c678e2f5b7a79a73f3ec1bb05512b3d /gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
parentfeatures/selinux/package.mask: mask for gnome-shell-extension (diff)
downloadgentoo-3b7d3b75913425bdc7c5782d988e4dd4f1f67fe8.tar.gz
gentoo-3b7d3b75913425bdc7c5782d988e4dd4f1f67fe8.tar.bz2
gentoo-3b7d3b75913425bdc7c5782d988e4dd4f1f67fe8.zip
gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: Allow to control blur on lock screen
Extension to allow to control blur effects on gnome-shell lock screen Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.ebuild56
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/metadata.xml7
3 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
new file mode 100644
index 000000000000..3cb8eb877582
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -0,0 +1 @@
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.tar.gz 3431 BLAKE2B 6355135f9027d53b10ba1f02f2fdf90dc0acbd090be8905addc78f22f7b136464831985152d8a112febc8891bbd18ea42aedd8009c7db4afc52ba48b6d502511 SHA512 322da0bc511bbb6943713fd3fc3d75d8f32b9872ced9eeb611acc77756392d0b9c9dc1311bdb4e255d131637de6a17a3d0a76f1cebcc71218d67d2ef6078a4d1
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.ebuild
new file mode 100644
index 000000000000..be15fbea50f5
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="824675a32d47346c89655f89b416e653f60c4d68"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.36.4
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/Control_Blur_Effect_On_Lock_Screen-${COMMIT}"
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ cd "${extension_uuid}"
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/metadata.xml b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>