summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-08-13 09:43:28 +0100
committerMatthew Smith <matthew@gentoo.org>2023-08-13 09:44:11 +0100
commit741f310b2c9fd757ce4f2f7384d07953fd0c3dff (patch)
tree73e4d28f1d00962ab44d71a9e92e686a2fb2fe6d /games-util
parentdev-ruby/sequel: new package, add 5.71.0 (diff)
downloadgentoo-741f310b2c9fd757ce4f2f7384d07953fd0c3dff.tar.gz
gentoo-741f310b2c9fd757ce4f2f7384d07953fd0c3dff.tar.bz2
gentoo-741f310b2c9fd757ce4f2f7384d07953fd0c3dff.zip
games-util/grfcodec: fix incompatibility with OpenTTD
Closes: https://bugs.gentoo.org/912189 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/files/grfcodec-6.0.6_p20230811-action-5.patch30
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6_p20230811-r1.ebuild (renamed from games-util/grfcodec/grfcodec-6.0.6_p20230811.ebuild)3
2 files changed, 33 insertions, 0 deletions
diff --git a/games-util/grfcodec/files/grfcodec-6.0.6_p20230811-action-5.patch b/games-util/grfcodec/files/grfcodec-6.0.6_p20230811-action-5.patch
new file mode 100644
index 000000000000..333c9f5ed2e9
--- /dev/null
+++ b/games-util/grfcodec/files/grfcodec-6.0.6_p20230811-action-5.patch
@@ -0,0 +1,30 @@
+Bug: https://bugs.gentoo.org/912189
+Upstream: https://github.com/OpenTTD/grfcodec/pull/23
+
+From de32367a6896c9f310fa48929e29643beaa08af4 Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matthew@gentoo.org>
+Date: Sun, 13 Aug 2023 09:30:01 +0100
+Subject: [PATCH] data: Fix Action5 table
+
+The alternative sprite counts were added into the action 5 table, but
+the counts were not updated. This caused all of the types defined after
+type 0x09 to be mis-read.
+
+Fixes: d5a7b850bcef30c0bfd17ceeb4a18c431770f468
+--- a/src/data.cpp
++++ b/src/data.cpp
+@@ -170,9 +170,9 @@ NDF_HEADER(0x04, 17),
+ /*06*/ OFFSET, OPTIONS(2), 0x4A, 0x5A,
+ /*07*/ OPTIONS(1), 0x5D,
+ /*08*/ OFFSET, OPTIONS(1), 0x41,
+-/*09*/ OFFSET, OPTIONS(1), 0x06, 0x12,
++/*09*/ OFFSET, OPTIONS(2), 0x06, 0x12,
+ /*0A*/ OFFSET | RECOLOUR | WORD, OPTIONS(1), W(0x100),
+-/*0B*/ OFFSET, OPTIONS(1), 0x71, 0x77,
++/*0B*/ OFFSET, OPTIONS(2), 0x71, 0x77,
+ /*0C*/ OPTIONS(1), 0x85,
+ /*0D*/ OPTIONS(2), 0x10, 0x12,
+ /*0E*/ MIXED, OPTIONS(1), 0x00,
+--
+2.41.0
+
diff --git a/games-util/grfcodec/grfcodec-6.0.6_p20230811.ebuild b/games-util/grfcodec/grfcodec-6.0.6_p20230811-r1.ebuild
index 9effc99b535d..600aa5d3e4a8 100644
--- a/games-util/grfcodec/grfcodec-6.0.6_p20230811.ebuild
+++ b/games-util/grfcodec/grfcodec-6.0.6_p20230811-r1.ebuild
@@ -22,6 +22,9 @@ DEPEND="${RDEPEND}
PATCHES=(
# Bug #894648
"${FILESDIR}"/${P}-no-fortify-source.patch
+
+ # Bug #912189
+ "${FILESDIR}"/${P}-action-5.patch
)
src_configure() {