summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:28:47 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:54:03 +0100
commit0c2c6b0a8fc4b07454c6fd034b0993da6aa87149 (patch)
tree9f42d8eaa22d020d8c109880b731faf624eabf5a /games-util
parentgames-emulation/ryujinx: add myself as a maintainer (diff)
downloadgentoo-0c2c6b0a8fc4b07454c6fd034b0993da6aa87149.tar.gz
gentoo-0c2c6b0a8fc4b07454c6fd034b0993da6aa87149.tar.bz2
gentoo-0c2c6b0a8fc4b07454c6fd034b0993da6aa87149.zip
games-util/dfarc: Port to wxGTK 3.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/dfarc/dfarc-3.14-r1.ebuild43
-rw-r--r--games-util/dfarc/files/dfarc-3.14-wxString.patch12
2 files changed, 55 insertions, 0 deletions
diff --git a/games-util/dfarc/dfarc-3.14-r1.ebuild b/games-util/dfarc/dfarc-3.14-r1.ebuild
new file mode 100644
index 000000000000..1f6a12e39977
--- /dev/null
+++ b/games-util/dfarc/dfarc-3.14-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit wxwidgets xdg
+
+DESCRIPTION="Frontend and .dmod installer for GNU FreeDink"
+HOMEPAGE="http://www.gnu.org/software/freedink/"
+SRC_URI="mirror://gnu/freedink/${P}.tar.gz"
+
+LICENSE="GPL-3 BZIP2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ app-arch/bzip2
+ x11-misc/xdg-utils
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( dev-util/intltool )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.12-nowindres.patch
+ # From OpenSuSE
+ "${FILESDIR}"/${P}-wxString.patch
+)
+
+src_configure() {
+ setup-wxwidgets
+ econf \
+ $(use_enable nls) \
+ --disable-desktopfiles \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ default
+ dodoc TRANSLATIONS.txt
+}
diff --git a/games-util/dfarc/files/dfarc-3.14-wxString.patch b/games-util/dfarc/files/dfarc-3.14-wxString.patch
new file mode 100644
index 000000000000..9eb7bd3ddffe
--- /dev/null
+++ b/games-util/dfarc/files/dfarc-3.14-wxString.patch
@@ -0,0 +1,12 @@
+diff -Nur dfarc-3.14/src/Tar.cpp new/src/Tar.cpp
+--- dfarc-3.14/src/Tar.cpp 2018-06-05 23:18:34.000000000 +0200
++++ new/src/Tar.cpp 2019-02-02 02:41:40.128841786 +0100
+@@ -610,7 +610,7 @@
+ if (lLastCharacter != '\\' && lLastCharacter != '/')
+ {
+ // Open the file.
+- std::ostream* lStreamOut = ostream_open_unicode(lCurrentFilePath);
++ std::ostream* lStreamOut = ostream_open_unicode(lCurrentFilePath.mb_str());
+ if (!lStreamOut->good())
+ {
+ wxLogError(_("Error: Improperly archived file '%s'. Skipping."), lCurrentFilePath);