summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-05 21:09:16 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-05 21:09:41 +0200
commit206da996be6c8149a20846d250b187cc5cf5cc23 (patch)
treee40a230b84e0d909a8387682ca146c3ff1333fed /games-strategy
parentgames-strategy/wesnoth: drop 1.17.20 (diff)
downloadgentoo-206da996be6c8149a20846d250b187cc5cf5cc23.tar.gz
gentoo-206da996be6c8149a20846d250b187cc5cf5cc23.tar.bz2
gentoo-206da996be6c8149a20846d250b187cc5cf5cc23.zip
games-strategy/wesnoth: add 1.19.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.19.1.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 7fcfd18a63d5..715b6e534e92 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,3 +1,4 @@
DIST wesnoth-1.16.10.tar.gz 518628374 BLAKE2B 7aaed481607bc58e9d0f22e4c4a36f24f19b4fc522ce3c1eb6366e70e3bd901a10f055d2add9dc1c73519368fd4a31cd6b326e42b1be0023eeda370076db0742 SHA512 0473ec4e4b7a33a37c2ff52b4e0c3dccec2e58a087517566967409dda03952127bf560b09cfccc7243f506201d98980aafdf289b7f1e5345a7e3b4316a908240
DIST wesnoth-1.18.0.tar.bz2 460686063 BLAKE2B 9dd898a6b430999873ae001dad47b2bcadcbbfc4672bf4489533c0268a4bf982a4e4451f79bf62bb1ac66d4ba2f06b62484b2b1b1fccb2e434c4ceef95a2c2bc SHA512 7c7cd1021d9af2e790f3973ae258d7e401b665102cfcdb9e7fb400471d8488b7fa3f35a17a32c53b646d707dcc0508fef379ae6ce2dc79f1d675a7b2ec0e50c2
DIST wesnoth-1.18.2.tar.bz2 461290798 BLAKE2B 6ff9538eca7f65e7413d9b220b07b5f76ad14b7853cb2b33195098f01544a6e3ba2603f927c55c2f5a42a4b3c148655483610beab985332737c4e0cf54be15df SHA512 de4d8ceaf29a93c174e9f832825542885bb90c4f481b6b248cc875cb0b1054435df3c2080c7693842b5e857af091e9219fa10b702d4fe63757f3d28871b63d4c
+DIST wesnoth-1.19.1.tar.bz2 461918324 BLAKE2B 8fa97526831e14957449a0b33909b7d155be00659d9543efbea34bd7935fb05b4e99a419dcc2e9c426a2e0fb4fb1d40c2972236d0da5a1661970eb80103f04fc SHA512 73ab7d474b01ac753224f0c694a86679a28160e340a07d87b8f96398df2c39c39df95098b750516e7e69851843e68954b5939ae68dc3a232ec2e9cad256d1113
diff --git a/games-strategy/wesnoth/wesnoth-1.19.1.ebuild b/games-strategy/wesnoth/wesnoth-1.19.1.ebuild
new file mode 100644
index 000000000000..19a65877e088
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.19.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls]
+ >=media-libs/libsdl2-2.0.18:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png,webp]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ local mycmakeargs=()
+
+ if use dedicated || use server ; then
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Allow SDL_Mixer test to pass, bug #931551
+ SDL_AUDIODRIVER=dummy cmake_src_test
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}