summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-strategy/wesnoth
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.7.ebuild10
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.9.ebuild9
-rw-r--r--games-strategy/wesnoth/wesnoth-1.15.2.ebuild9
3 files changed, 13 insertions, 15 deletions
diff --git a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
index 510a59e68be9..06ff63ec4324 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.7.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils user
+
+inherit cmake user
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -55,7 +56,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -106,14 +107,13 @@ src_configure() {
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_OMP="$(usex openmp)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
diff --git a/games-strategy/wesnoth/wesnoth-1.14.9.ebuild b/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
index 807170165f0b..0451aedf6acf 100644
--- a/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.14.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user xdg
+inherit cmake user xdg
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -100,14 +100,13 @@ src_configure() {
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
diff --git a/games-strategy/wesnoth/wesnoth-1.15.2.ebuild b/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
index 807170165f0b..0451aedf6acf 100644
--- a/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.15.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user xdg
+inherit cmake user xdg
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -50,7 +50,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use doc ; then
sed -i \
@@ -100,14 +100,13 @@ src_configure() {
-DENABLE_NOTIFICATIONS="$(usex dbus)"
-DENABLE_FRIBIDI="$(usex fribidi)"
-DENABLE_STRICT_COMPILATION="OFF"
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
local DOCS=( README.md changelog.md )
- cmake-utils_src_install
+ cmake_src_install
if use dedicated || use server; then
rmdir "${ED}/run/wesnothd" || die
newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd