summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-20 22:53:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-20 23:38:19 -0400
commitbfdfce2c5717f2fc7a13713dedf92e3141292ce3 (patch)
tree8228ff8e535d7bd8504f4fea88dd446c7e1528b6 /games-strategy/tornado/files
parentgames-strategy/tornado: EAPI8 bump, minor improvements (diff)
downloadgentoo-bfdfce2c5717f2fc7a13713dedf92e3141292ce3.tar.gz
gentoo-bfdfce2c5717f2fc7a13713dedf92e3141292ce3.tar.bz2
gentoo-bfdfce2c5717f2fc7a13713dedf92e3141292ce3.zip
games-strategy/tornado: simplify patch and support prefix
Manual install rather than a 13kB patch that adds DESTDIR everywhere and ignored EPREFIX. Also made nls unconditional as it uses libintl.h either way (but allowing selection through plocale.eclass). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy/tornado/files')
-rw-r--r--games-strategy/tornado/files/tornado-1.4-make.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/games-strategy/tornado/files/tornado-1.4-make.patch b/games-strategy/tornado/files/tornado-1.4-make.patch
new file mode 100644
index 000000000000..1dc2ac703446
--- /dev/null
+++ b/games-strategy/tornado/files/tornado-1.4-make.patch
@@ -0,0 +1,19 @@
+Respect flags and use pkg-config.
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,2 @@
+-CC = gcc
+-MAKE = make
+-LDFLAGS = -lncurses
++LIBS := $(shell $(PKG_CONFIG) --libs ncurses) $(LIBS)
+ OBJFILES = main.o draw.o erwin.o network.o scores.o
+@@ -6,3 +4,3 @@
+ LOCALEPATH = /usr/local/share/locale
+-CFLAGS = -Wall -O2 -DPREFIX="\"$(PREFIX)\""
++CFLAGS := $(CFLAGS) -Wall -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\"" $(shell $(PKG_CONFIG) --cflags ncurses) $(CPPFLAGS)
+ VERSION = `grep " VERSION" version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
+@@ -27,3 +25,3 @@
+ tornado: $(OBJFILES)
+- $(CC) $(LDFLAGS) $(OBJFILES) -o tornado
++ $(CC) $(LDFLAGS) $(OBJFILES) -o tornado $(LIBS)
+