summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-20 14:39:48 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-20 14:40:13 -0400
commitb631809ebee511cf95235b92ff32ee0808ebbcd0 (patch)
tree506426d340f2a7b73726608237c2ed786275b51e /games-strategy/s25rttr
parentnet-analyzer/icinga2: bup (diff)
downloadgentoo-b631809ebee511cf95235b92ff32ee0808ebbcd0.tar.gz
gentoo-b631809ebee511cf95235b92ff32ee0808ebbcd0.tar.bz2
gentoo-b631809ebee511cf95235b92ff32ee0808ebbcd0.zip
games-strategy/s25rttr: make cmake3 quieter with patch from tt_1 via bug #570716
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-strategy/s25rttr')
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.8.1-cmake-3.patch23
-rw-r--r--games-strategy/s25rttr/s25rttr-0.8.1-r1.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake-3.patch b/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake-3.patch
new file mode 100644
index 000000000000..b7e9e424eb08
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-0.8.1-cmake-3.patch
@@ -0,0 +1,23 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fcbfb02..ae1c5f0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,12 +2,12 @@
+ ### $Id: CMakeLists.txt 8341 2012-09-30 12:09:04Z FloSoft $
+ ################################################################################
+
+-CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0)
+-CMAKE_POLICY(SET CMP0003 OLD)
+-
+-IF(${CMAKE_MAJOR_VERSION} EQUAL 2 AND ${CMAKE_MINOR_VERSION} GREATER 7 AND ${CMAKE_PATCH_VERSION} GREATER 0)
+- CMAKE_POLICY(SET CMP0015 OLD)
+-ENDIF(${CMAKE_MAJOR_VERSION} EQUAL 2 AND ${CMAKE_MINOR_VERSION} GREATER 7 AND ${CMAKE_PATCH_VERSION} GREATER 0)
++CMAKE_MINIMUM_REQUIRED(VERSION 2.8.7)
++CMAKE_POLICY(SET CMP0003 NEW)
++CMAKE_POLICY(SET CMP0015 NEW)
++IF(NOT CMAKE_VERSION VERSION_LESS 3.1)
++ CMAKE_POLICY(SET CMP0053 NEW)
++ENDIF()
+
+ SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules)
+
diff --git a/games-strategy/s25rttr/s25rttr-0.8.1-r1.ebuild b/games-strategy/s25rttr/s25rttr-0.8.1-r1.ebuild
index 15d30987c1a4..b8d00d7bf990 100644
--- a/games-strategy/s25rttr/s25rttr-0.8.1-r1.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.8.1-r1.ebuild
@@ -33,7 +33,8 @@ src_prepare() {
"${FILESDIR}"/${P}-soundconverter.patch \
"${FILESDIR}"/${P}-fpic.patch \
"${FILESDIR}"/${P}-format.patch \
- "${FILESDIR}"/${P}-miniupnpc-api-14.patch
+ "${FILESDIR}"/${P}-miniupnpc-api-14.patch \
+ "${FILESDIR}"/${P}-cmake-3.patch
}
src_configure() {