summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-24 01:59:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-24 01:59:38 +0100
commitb2dcda6e1c4d2db4ada1e73f014860353977874f (patch)
tree6fea4a47eff5095d03991a88bbbd819bb12a8204 /games-strategy/freeciv
parentdev-lang/rust: print a warning if symlink target not found (diff)
downloadgentoo-b2dcda6e1c4d2db4ada1e73f014860353977874f.tar.gz
gentoo-b2dcda6e1c4d2db4ada1e73f014860353977874f.tar.bz2
gentoo-b2dcda6e1c4d2db4ada1e73f014860353977874f.zip
games-strategy/freeciv: Fix path to Qt5 moc with qmake-utils.eclass
Closes: https://bugs.gentoo.org/756262 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-strategy/freeciv')
-rw-r--r--games-strategy/freeciv/freeciv-2.6.2.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/games-strategy/freeciv/freeciv-2.6.2.ebuild b/games-strategy/freeciv/freeciv-2.6.2.ebuild
index 1b61b770630f..e361752c4a59 100644
--- a/games-strategy/freeciv/freeciv-2.6.2.ebuild
+++ b/games-strategy/freeciv/freeciv-2.6.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PV="${PV/_beta/-beta}"
MY_PV="${MY_PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"
-inherit desktop flag-o-matic xdg
+inherit desktop flag-o-matic qmake-utils xdg
DESCRIPTION="multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
@@ -129,6 +129,7 @@ src_configure() {
use sdl && myclient+=( sdl2 )
use gtk && myclient+=( gtk2 )
if use qt5 ; then
+ local -x MOCCMD=$(qt5_get_bindir)/moc
myclient+=( qt )
append-cxxflags -std=c++11
fi