summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/dunelegacy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/dunelegacy')
-rw-r--r--games-strategy/dunelegacy/Manifest2
-rw-r--r--games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild58
-rw-r--r--games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch60
-rw-r--r--games-strategy/dunelegacy/metadata.xml22
4 files changed, 142 insertions, 0 deletions
diff --git a/games-strategy/dunelegacy/Manifest b/games-strategy/dunelegacy/Manifest
new file mode 100644
index 000000000000..7403b798e146
--- /dev/null
+++ b/games-strategy/dunelegacy/Manifest
@@ -0,0 +1,2 @@
+DIST dunelegacy-0.96.3-no-autoreconf.patch.xz 8908 SHA256 fae291f43c01bcf6af437602738b506631a1f0aea2b680912ffb5e1280507975 SHA512 fc17c771a19611057b2990b76eda0eea08e011dcac455bdf7e26bba1f2e2aa6cec120f2dcbce488a2318553f9e58b4a2b5ea24c7e1e27ada9ec5740f2b66ca4c WHIRLPOOL 707abf066efbaafd95063aca23d1cdfdd6c5b01f16b5d0952b8cb4f765d08dcd0316c8876522c7bfdd476801dd1b0eab7aa0069ae0cd5bbe78118de50810d40c
+DIST dunelegacy-0.96.3-src.tar.bz2 1652302 SHA256 677159c174d9f9e8eb20e5e5cec997decf8e5a7091dc1583dc23fe340c5f6222 SHA512 c84281b44bdac4eec360d90e2f23aa75468cf08c6edd6a5002c539e609312fd39e3284518ef5498201f2b0433d11cf2478cd13a2159af7c6bbef326e680fa241 WHIRLPOOL a90330135e74ee2875c18f8696aee9598cee07e185d6f7759f180d9934e5e063e0a5b449644e2744d8e480e9be35bb93277d71d0a021f3dccb0541540ef84439
diff --git a/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
new file mode 100644
index 000000000000..1c2b88ebc391
--- /dev/null
+++ b/games-strategy/dunelegacy/dunelegacy-0.96.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# do not use autotools related stuff in stable ebuilds
+# unless you like random breakage: 469796, 469798, 424041
+
+EAPI=5
+inherit eutils gnome2-utils games # STABLE ARCH
+#inherit autotools eutils gnome2-utils games # UNSTABLE ARCH
+
+DESCRIPTION="Updated clone of Westood Studios' Dune2"
+HOMEPAGE="http://dunelegacy.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~hasufell/distfiles/${P}-no-autoreconf.patch.xz" # STABLE ARCH
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="+alsa pulseaudio"
+
+RDEPEND="media-libs/libsdl[X,alsa?,sound,pulseaudio?,video]
+ media-libs/sdl-mixer[midi,mp3,vorbis]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# exits on start without libsdl[alsa] or libsdl[pulseaudio]
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-no-autoreconf.patch.xz # STABLE ARCH
+# epatch "${FILESDIR}"/${P}-build.patch # UNSTABLE ARCH
+# eautoreconf # UNSTABLE ARCH
+}
+
+src_install() {
+ default
+
+ doicon -s scalable ${PN}.svg
+ doicon -s 48 ${PN}.png
+ make_desktop_entry ${PN} "Dune Legacy"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch b/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch
new file mode 100644
index 000000000000..93dd907738bc
--- /dev/null
+++ b/games-strategy/dunelegacy/files/dunelegacy-0.96.3-build.patch
@@ -0,0 +1,60 @@
+Author: hasufell <hasufell@gentoo.org>
+Date: Thu Aug 9 18:57:40 2012 +0200
+
+ respect flags
+ use pkg-config
+ use LDADD instead of LDFLAGS for libs
+
+--- configure.ac
++++ configure.ac
+@@ -16,14 +16,6 @@
+
+ AC_SUBST(dunelegacydatadir)
+
+-dnl Some flags for gcc
+-CXXFLAGS="-O3 -pipe -pedantic -Wall -Wextra -Wno-unused-parameter -DNDEBUG"
+-dnl Additional flags: -Wconversion -Wno-sign-conversion
+-
+-dnl Some flags for clang
+-dnl CXXFLAGS="-O3 -pipe -pedantic -Weverything -Wno-sign-conversion -Wno-conversion -Wno-shadow -Wno-missing-noreturn -Wno-padded -Wno-packed -Wno-weak-vtables -Wno-c++11-narrowing -Wno-cast-align -Wno-unreachable-code -Wno-missing-prototypes -Wno-float-equal -Wno-global-constructors -Wno-exit-time-destructors -Wno-format-nonliteral -Wno-unused-macros -Wextra -Wno-unused-parameter"
+-
+-
+ dnl test for -ffp-contract=off (gcc >= 4.6) and use -mno-fused-madd instead
+ oldCFLAGS="$CFLAGS"
+ CFLAGS="-ffp-contract=off"
+@@ -33,34 +25,14 @@
+ )
+ CFLAGS="$oldCFLAGS"
+
+-case "$target_cpu" in
+-i*86) CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse";;
+-esac
+-
+-AC_ARG_ENABLE([debug],
+- [AS_HELP_STRING([--enable-debug],
+- [compile with debug information @<:@default=disabled@:>@])],
+- [],
+- [])
+-
+-if test "$enable_debug" = "yes" ; then
+- CXXFLAGS="$CXXFLAGS -g"
+-fi
+
+ dnl Check for SDL library
+ SDL_VERSION=1.2.0
+-AM_PATH_SDL($SDL_VERSION, : , AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]))
++PKG_CHECK_MODULES([SDL], [sdl >= $SDL_VERSION SDL_mixer])
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
+
+-dnl Check for SDL_mixer library.
+-AC_CHECK_LIB(SDL_mixer,
+- Mix_OpenAudio,
+- LIBS="$LIBS -lSDL_mixer",
+- AC_MSG_ERROR([*** SDL_mixer library not found!])
+-)
+-
+ dnl enet defines
+ AC_CHECK_FUNC(gethostbyaddr_r, [AC_DEFINE(HAS_GETHOSTBYADDR_R)])
+ AC_CHECK_FUNC(gethostbyname_r, [AC_DEFINE(HAS_GETHOSTBYNAME_R)])
diff --git a/games-strategy/dunelegacy/metadata.xml b/games-strategy/dunelegacy/metadata.xml
new file mode 100644
index 000000000000..34c0e00fd987
--- /dev/null
+++ b/games-strategy/dunelegacy/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <bugs-to>http://sourceforge.net/apps/mediawiki/dunelegacy/index.php?title=Development/Reporting_Bugs</bugs-to>
+ <remote-id type="sourceforge">dunelegacy</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Dune Legacy is an effort by a handful of developers to revitalize
+ the first-ever real-time strategy game. The original game was the
+ basis for the hugely successful Command and Conquer series, and the
+ gameplay has been replicated an extended to a wide variety of
+ storylines and series.
+
+ Lead one of three interplanetary houses, Atreides, Harkonnen or
+ Ordos, in an attempt to harvest the largest amount of spice from
+ the sand dunes. Exchange your spice stockpiles for credits through
+ refinement and build an army capable of thwarting attempts of the
+ other houses to stop your harvesting!
+ </longdescription>
+</pkgmetadata>