summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-08-12 09:25:01 +0200
committerSam James <sam@gentoo.org>2021-08-15 21:56:57 +0100
commit688ecac307728b83030e2d49f80cae7fefe62f52 (patch)
treeb45f0af062bf775d2aafc7900498da1c4807841b /games-strategy/0ad
parentgames-strategy/0ad: Bump to 0.0.25_alpha, unbundle premake (diff)
downloadgentoo-688ecac307728b83030e2d49f80cae7fefe62f52.tar.gz
gentoo-688ecac307728b83030e2d49f80cae7fefe62f52.tar.bz2
gentoo-688ecac307728b83030e2d49f80cae7fefe62f52.zip
games-strategy/0ad: Remove the old pre-alpha-24(!) version
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/21931 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy/0ad')
-rw-r--r--games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild232
-rw-r--r--games-strategy/0ad/Manifest1
2 files changed, 0 insertions, 233 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild b/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild
deleted file mode 100644
index 849ecb4aaef8..000000000000
--- a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild
+++ /dev/null
@@ -1,232 +0,0 @@
-# Copyright 2014-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-WX_GTK_VER="3.0-gtk3"
-PYTHON_COMPAT=( python3_{7..9} )
-inherit desktop toolchain-funcs python-any-r1 wxwidgets xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/0ad/0ad"
- ZEROAD_GIT_REVISION=""
-elif [[ ${PV} == *_pre* ]]; then
- ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
-else
- MY_P="0ad-${PV/_/-}"
-fi
-
-DESCRIPTION="A free, real-time strategy game"
-HOMEPAGE="https://play0ad.com/"
-if [[ ${PV} == 9999 ]]; then
- SRC_URI=""
-elif [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
-else
- SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
-fi
-
-# merged with 0ad-data
-# addresses comment #3
-# bug #771147
-LICENSE="CC-BY-SA-3.0 GPL-2 LGPL-2.1 MIT ZLIB BitstreamVera LPPL-1.3c"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="editor +lobby nvtt pch test"
-RESTRICT="test"
-
-# virtual/rust is for bundled SpiderMonkey
-# Build-time Python dependency is for SM too
-# TODO: Unbundle premake5
-# See bug #773472 which may help (bump for it)
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- virtual/rust
- test? ( dev-lang/perl )
-"
-# remove dependency on nvtt
-# as we use the bundled one
-# bug #768930
-DEPEND="
- dev-libs/boost:=
- dev-libs/icu:=
- dev-libs/libfmt:0=
- dev-libs/libsodium
- dev-libs/libxml2
- media-libs/libpng:0
- media-libs/libsdl2[X,opengl,video]
- media-libs/libvorbis
- media-libs/openal
- net-libs/enet:1.3
- net-libs/miniupnpc:=
- net-misc/curl
- sys-libs/zlib
- virtual/opengl
- x11-libs/libX11
- editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
- lobby? ( >=net-libs/gloox-1.0.20 )"
-
-# add block on 0ad-data, as it is no longer needed.
-# addresses comment #3
-# bug #771147
-RDEPEND="${DEPEND}
- !games-strategy/0ad-data"
-
-if [[ ${PV} == 9999 ]]; then
- S="${WORKDIR}/${P}"
-elif [[ ${PV} == *_pre* ]]; then
- S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
-else
- S="${WORKDIR}/${MY_P}"
-fi
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.0.24_alpha_pre20210116040036-build.patch"
-)
-
-pkg_setup() {
- use editor && setup-wxwidgets
-}
-
-src_prepare() {
- default
-
- sed -i -e "/--build/d" libraries/source/spidermonkey/build.sh || die
-
- # merged from 0ad-data
- # addresses comment #3
- # bug #771147
- rm binaries/data/tools/fontbuilder/fonts/*.txt || die
-}
-
-src_configure() {
- local myconf=(
- --minimal-flags
- $(usex nvtt "" "--without-nvtt")
- $(usex pch "" "--without-pch")
- $(usex test "" "--without-tests")
- $(usex editor "--atlas" "")
- $(usex lobby "" "--without-lobby")
- --bindir="/usr/bin"
- --libdir="/usr/$(get_libdir)"/${PN}
- --datadir="/usr/share/${PN}"
- )
-
- tc-export CC CXX
-
- # stock premake5 does not work, use the shipped one
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix
-
- # regenerate scripts.c so our patch applies
- cd "${S}"/build/premake/premake5 || die
- "${S}"/build/premake/premake5/bin/release/premake5 embed || die
-
- # rebuild premake again... this is the most stupid build system
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix clean
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix
-
- # run premake to create build scripts
- cd "${S}"/build/premake || die
- "${S}"/build/premake/premake5/bin/release/premake5 \
- --file="premake5.lua" \
- --outpath="../workspaces/gcc/" \
- --os=linux \
- "${myconf[@]}" \
- gmake2 || die "Premake failed"
-}
-
-src_compile() {
- tc-export AR
-
- # build 3rd party fcollada
- einfo "Building bundled fcollada"
- emake -C libraries/source/fcollada/src
-
- # build bundled nvtt
- # nvtt is abandoned upstream and 0ad have forked it
- # and added fixes. Use their copy.
- # bug #768930
- if use nvtt ; then
- cd libraries/source/nvtt || die
- elog "Building bundled nvtt (bug #768930)"
- ./build.sh || die "Failed to build bundled nvtt"
- cd "${S}" || die
- fi
-
- # build bundled spidermonkey
- # We genuinely can't use the system SpiderMonkey right now.
- # Breakages occur even on minor bumps in upstream SM,
- # e.g. bug #768840.
- cd libraries/source/spidermonkey || die
- elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" ./build.sh || die "Failed to build bundled SpiderMonkey"
- cd "${S}" || die
-
- # build 0ad
- elog "Building 0ad"
- emake -C build/workspaces/gcc verbose=1
-
- # merged from 0ad-data
- # addresses comment #3
- # bug #771147
- if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
- # source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
- addpredict /proc/self/task
-
- # Based on source/tools/dist/build-archives.sh used by source/tools/dist/build.sh.
- local archivebuild_input archivebuild_output mod_name
- for archivebuild_input in binaries/data/mods/[A-Za-z0-9]*; do
- mod_name="${archivebuild_input##*/}"
- archivebuild_output="archives/${mod_name}"
-
- mkdir -p "${archivebuild_output}"
-
- einfo pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
- LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip" || die
-
- if [[ -f "${archivebuild_input}/mod.json" ]]; then
- cp "${archivebuild_input}/mod.json" "${archivebuild_output}"
- fi
-
- rm -r "${archivebuild_input}" || die
- mv "${archivebuild_output}" "${archivebuild_input}" || die
- done
-
- # Based on source/tools/dist/build-unix-win32.sh used by source/tools/dist/build.sh.
- rm binaries/data/config/dev.cfg || die
- rm -r binaries/data/mods/_test.* || die
- fi
-}
-
-src_test() {
- cd binaries/system || die
- ./test -libdir "${S}/binaries/system" || die "test phase failed"
-}
-
-src_install() {
- newbin binaries/system/pyrogenesis 0ad
- use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
-
- # merged with 0ad-data
- # addresses comment #3
- # bug #771147
- insinto /usr/share/${PN}
- doins -r binaries/data/{l10n,config,mods,tools}
-
- # merged with 0ad-data
- # addresses comment #3
- # bug #771147
- # install bundled SpiderMonkey and nvtt
- # fixes comment #1
- # bug #771147
- exeinto /usr/$(get_libdir)/${PN}
- doexe binaries/system/{libCollada,libmozjs78-ps-release,libnvtt,libnvcore,libnvimage,libnvmath}.so
- use editor && doexe binaries/system/libAtlasUI.so
-
- dodoc binaries/system/readme.txt
- doicon -s 128 build/resources/${PN}.png
- make_desktop_entry ${PN}
-}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index 42d9a470983b..466a2877ccf1 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -1,4 +1,3 @@
-DIST 0ad-0.0.24_alpha_pre20210116040036.tar.gz 2562395684 BLAKE2B 03d6655f7aa1f2f91a87536a7f2afa465585856c4209ddc05e666e1e5596416883596331118ac4257ff314b04d8a5c08821eaa6ae76e5d3095146ab04f8c79ed SHA512 e1239a56b184a87708c87fc03ca41190a16d813e495c5d81ee073df98761f1524a23902e5d03a21a1b1f657b496fce6eeee4a5ef22eee30f70fbe3b0dbd44510
DIST 0ad-0.0.24b-alpha-unix-build.tar.xz 75546740 BLAKE2B a724abba6bed4b580670588e9dcfe0f75f6cef0fbde6ad666356e96213c685932edd0a1daafb5dd04206870c2c8222340c9c51e83076ec2911cbb5377ca00666 SHA512 8173d393eb1bc57c38bef0076ba973ef46c877c06644365189c0887cd3152adba51d26b553e42221fd14343e9830a3a275bfcd9b28f66281e282ea3f247730ea
DIST 0ad-0.0.24b-alpha-unix-data.tar.xz 828553992 BLAKE2B 2081225d88d475ed0899648994a900677bc3280bb2ba6cf92354ece82b90ddcefddb48458fa23e2de97100e58f4db8db408d4b50d0306a8c3efe47d263064bf0 SHA512 d7804d25ddf376028f230a31c6fc1201dfa366b3d5434569a1a7852bb4c400fb14e5c8934c5d6c6295320cf2e62c64be83b1e3c4c27fd116115bfe7d01106726
DIST 0ad-0.0.25-alpha-unix-build.tar.xz 75788348 BLAKE2B 49b8b99a8f2fd33d4a3c2c0320375cb372d23b2f2c0f4ba56438bc8d868891c8c8c624049e3165ec84f8b98bcb1e1195b672aa7ee258ff88317af9d4da883576 SHA512 a8edae7d2dd61972b947152edda8d9ca8bafd3d435623a94de2d1297ecad3bfc73d3b30eaff98e89a6bcb0291b49f1e25bae1300fde37c8989156c895cd12730