summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/speed-dreams
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/speed-dreams')
-rw-r--r--games-sports/speed-dreams/Manifest1
-rw-r--r--games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch110
-rw-r--r--games-sports/speed-dreams/files/speed-dreams-1.4.0-automake.patch35
-rw-r--r--games-sports/speed-dreams/files/speed-dreams-1.4.0-libpng15.patch20
-rw-r--r--games-sports/speed-dreams/metadata.xml11
-rw-r--r--games-sports/speed-dreams/speed-dreams-1.4.0.ebuild83
6 files changed, 260 insertions, 0 deletions
diff --git a/games-sports/speed-dreams/Manifest b/games-sports/speed-dreams/Manifest
new file mode 100644
index 000000000000..c5b899dc14ac
--- /dev/null
+++ b/games-sports/speed-dreams/Manifest
@@ -0,0 +1 @@
+DIST speed-dreams-1.4.0-r2307-src.tar.bz2 332667666 SHA256 c109bb77785e33ab66992db8566584f4393d2f141fb12e32a58793953fcd6893
diff --git a/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch b/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch
new file mode 100644
index 000000000000..837a2511a191
--- /dev/null
+++ b/games-sports/speed-dreams/files/speed-dreams-1.4.0-asneeded.patch
@@ -0,0 +1,110 @@
+--- configure.in
++++ configure.in
+@@ -123,8 +123,7 @@
+ AC_CHECK_LIB(Xrandr, XRRQueryVersion,,AC_MSG_ERROR([Can't find libXrandr. Please check config.log and if you can't solve the problem send the file to speed-dreams-users@lists.sourceforge.net with the subject \"Speed Dreams compilation problem\"]))
+ AC_CHECK_LIB(openal, alEnable,, AC_MSG_ERROR([Can't find AL/al.h. OpenAL can be found on http://www.openal.org/]))
+ AC_CHECK_LIB(alut, alutLoadWAVFile,
+- LDFLAGS="$LDFLAGS -lalut",
+- LDFLAGS="$LDFLAGS")
++ LIBS="$LIBS -lalut", )
+
+ AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_FUNC(dlopen,,AC_MSG_ERROR([Can't find dlopen function. Please check config.log and if you can't solve the problem send the file to speed-dreams-users@lists.sourceforge.net with the subject \"Speed Dreams compilation problem\"]))
+@@ -141,7 +140,7 @@
+ AC_CHECK_LIB(glut, glutSwapBuffers,,AC_MSG_ERROR([Can't find libglut. freeglut can be found on http://freeglut.sourceforge.net/]))
+
+ dnl Checks for plib libraries.
+-LDFLAGS="$LDFLAGS -lplibjs"
++AC_CHECK_LIB(plibjs, main,,AC_MSG_ERROR([Can't find libplibjs. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibul, main,,AC_MSG_ERROR([Can't find libplibul. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibsg, main,,AC_MSG_ERROR([Can't find libplibsg. PLIB can be found on http://plib.sourceforge.net/]))
+ AC_CHECK_LIB(plibsl, main,,AC_MSG_ERROR([Can't find libplibsl. PLIB can be found on http://plib.sourceforge.net/]))
+--- Make-default.mk
++++ Make-default.mk
+@@ -402,7 +402,7 @@
+ ifdef PROGRAM
+
+ ${PROGRAM}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${SOLIBS} ${EXT_LIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installprogram: ${PROGRAM}
+ @ createdir="${INSTLIBBASE}" ; \
+@@ -420,14 +420,14 @@
+ ifdef LOCALTOOLS
+
+ ${LOCALTOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ endif
+
+ ifdef TOOLS
+
+ ${TOOLS}: ${OBJECTS} $(subst -l,${EXPORTBASE}/lib/lib, ${LIBS:=.a})
+- ${CXX} ${OBJECTS} ${LDFLAGS} ${LIBS} ${EXT_LIBS} ${SOLIBS} -o $@
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -o $@ ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+
+ installtools: ${TOOLS}
+ @createdir="${INSTBINBASE}/${TOOLSDIR}" ; \
+@@ -478,7 +478,7 @@
+ ifdef SOLIBRARY
+
+ ${SOLIBRARY}: ${OBJECTS}
+- ${CXX} -shared -o ${SOLIBRARY} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS} ${DEBUG_LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${SOLIBRARY} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/lib" ; \
+ $(mkinstalldirs) $$createdir ; \
+@@ -509,7 +509,7 @@
+ ifdef MODULE
+
+ ${MODULE}: ${OBJECTS}
+- ${CXX} -shared -o ${MODULE} ${OBJECTS} ${LDFLAGS} ${LIBSPATH} ${LIBS}
++ ${CXX} ${CXXFLAGS} ${LDFLAGS} -shared -o ${MODULE} ${OBJECTS} ${SOLIBS} ${LIBS} ${EXT_LIBS}
+ @D=`pwd` ; \
+ createdir="${EXPORTBASE}/${MODULEDIR}" ; \
+ $(mkinstalldirs) $$createdir ; \
+--- src/libs/client/Makefile
++++ src/libs/client/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = entry.cpp mainmenu.cpp splash.cpp exitmenu.cpp \
+ optionmenu.cpp
+
++SOLIBS = -lconfscreens -lraceengine
++
+ LIBS = -lplibssg -lplibsg -lplibul
+
+ EXPDIR = include
+--- src/libs/Makefile
++++ src/libs/Makefile
+@@ -23,7 +23,7 @@
+
+ TOOLSUBDIRS = txml
+
+-SUBDIRS = confscreens racescreens robottools txml tgf tgfclient client raceengineclient learning \
++SUBDIRS = confscreens racescreens robottools txml tgf tgfclient raceengineclient client learning \
+ portability math
+
+ PKGSUBDIRS = $(SUBDIRS)
+--- src/libs/raceengineclient/Makefile
++++ src/libs/raceengineclient/Makefile
+@@ -23,6 +23,8 @@
+ SOURCES = singleplayer.cpp raceinit.cpp racemain.cpp racemanmenu.cpp racestate.cpp racegl.cpp \
+ raceengine.cpp raceresults.cpp
+
++SOLIBS = -lconfscreens -lrobottools -lracescreens
++
+ EXPDIR = include
+
+ EXPORTS = singleplayer.h raceinit.h
+--- src/libs/tgf/Makefile
++++ src/libs/tgf/Makefile
+@@ -29,6 +29,7 @@
+ profiler.cpp \
+ hash.cpp
+
++SOLIBS = -ltxml
+
+ EXPDIR = include
+
diff --git a/games-sports/speed-dreams/files/speed-dreams-1.4.0-automake.patch b/games-sports/speed-dreams/files/speed-dreams-1.4.0-automake.patch
new file mode 100644
index 000000000000..56f9b9bab642
--- /dev/null
+++ b/games-sports/speed-dreams/files/speed-dreams-1.4.0-automake.patch
@@ -0,0 +1,35 @@
+--- configure.in.old 2012-03-13 08:15:34.891163505 +0100
++++ configure.in 2012-03-13 08:18:40.154092687 +0100
+@@ -14,9 +14,10 @@
+ #
+ ##############################################################################
+
+-AC_INIT(Make-config.in)
++AC_INIT([speed-dreams], [1.4.0-r2307])
++AC_CONFIG_SRCDIR([Make-config.in])
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE(speed-dreams, 1.4.0-r2307)
++AC_DEFINE(VERSION, ["1.4.0-r2307"], [Version])
+
+ dnl Checks for programs.
+ AC_PROG_CC
+--- Makefile.old 2012-03-13 10:43:30.563720337 +0100
++++ Makefile 2012-03-13 10:44:26.339794119 +0100
+@@ -88,17 +88,7 @@
+ -include ${MAKE_DEFAULT}
+
+ Make-config: configure Make-config.in
+- rm -f config.status config.log config.cache
+ ./configure
+- rm -f config.status config.log config.cache
+-
+-configure: configure.in config.h.in aclocal.m4
+- rm -f config.status config.log config.cache
+- autoheader
+- autoconf
+-
+-aclocal.m4: acinclude.m4
+- aclocal
+
+ distclean: clean
+ rm -f config.status config.log config.cache
diff --git a/games-sports/speed-dreams/files/speed-dreams-1.4.0-libpng15.patch b/games-sports/speed-dreams/files/speed-dreams-1.4.0-libpng15.patch
new file mode 100644
index 000000000000..6b09ce2a41c8
--- /dev/null
+++ b/games-sports/speed-dreams/files/speed-dreams-1.4.0-libpng15.patch
@@ -0,0 +1,20 @@
+--- a/src/libs/tgfclient/img.cpp
++++ b/src/libs/tgfclient/img.cpp
+@@ -98,7 +98,7 @@
+ return (unsigned char *)NULL;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+@@ -229,7 +229,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return -1;
diff --git a/games-sports/speed-dreams/metadata.xml b/games-sports/speed-dreams/metadata.xml
new file mode 100644
index 000000000000..7f5789ee7fb3
--- /dev/null
+++ b/games-sports/speed-dreams/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="xrandr">Enable support for the X xrandr extension</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">speed-dreams</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
new file mode 100644
index 000000000000..a45859f1808f
--- /dev/null
+++ b/games-sports/speed-dreams/speed-dreams-1.4.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils versionator games
+
+DESCRIPTION="A fork of the famous open racing car simulator TORCS"
+HOMEPAGE="http://speed-dreams.sourceforge.net/"
+SRC_URI="mirror://sourceforge/speed-dreams/${P}-r2307-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="xrandr"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/freeglut
+ media-libs/openal
+ media-libs/freealut
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ xrandr? ( x11-libs/libXrandr )
+ sys-libs/zlib
+ >=media-libs/libpng-1.2.40"
+DEPEND="${RDEPEND}
+ >=media-libs/plib-1.8.3
+ x11-proto/xproto
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXrender
+ xrandr? ( x11-proto/randrproto )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)-src
+
+src_prepare() {
+ # http://sourceforge.net/apps/trac/speed-dreams/ticket/111
+ MAKEOPTS="${MAKEOPTS} -j1"
+
+ epatch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-automake.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
+
+ sed -i \
+ -e '/ADDCFLAGS/s: -O2::' \
+ configure.in || die
+ sed -i \
+ -e '/COPYING/s:=.*:= \\:' \
+ Makefile || die
+ sed -i \
+ -e "/^datadir/s:=.*:= ${GAMES_DATADIR}/${PN}:" \
+ Make-config.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ addpredict $(echo /dev/snd/controlC? | sed 's/ /:/g')
+ [[ -e /dev/dsp ]] && addpredict /dev/dsp
+ egamesconf \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_enable xrandr)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install datainstall
+
+ find "${D}" -name Makefile -exec rm -f {} +
+
+ dodoc CHANGES README TODO
+
+ newicon icon.svg ${PN}.svg
+ make_desktop_entry ${PN} "Speed Dreams"
+
+ prepgamesdirs
+}