summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-02 01:57:37 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-02 05:16:24 -0400
commitf34e54ba63130f9366ea71a71e9a8101fd81a5d1 (patch)
tree9b3cce89930d280774606d72bacd32d37d73f95c /games-simulation/lincity
parentgames-simulation/gl117: EAPI6->8, replace homepage, fix icon (diff)
downloadgentoo-f34e54ba63130f9366ea71a71e9a8101fd81a5d1.tar.gz
gentoo-f34e54ba63130f9366ea71a71e9a8101fd81a5d1.tar.bz2
gentoo-f34e54ba63130f9366ea71a71e9a8101fd81a5d1.zip
games-simulation/lincity: EAPI6->8, fix prefix, add icon
* Strip part of the patch that was formerly intended for games.eclass but now only broke prefix * Update DESCRIPTION to reflect svgalib isn't supported * Remove not-really-used libSM dependency * Use xlincity.6 man page name to match installed binary Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-simulation/lincity')
-rw-r--r--games-simulation/lincity/Manifest1
-rw-r--r--games-simulation/lincity/files/lincity-1.13.1-build.patch38
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r1.ebuild53
-rw-r--r--games-simulation/lincity/lincity-1.13.1-r2.ebuild62
4 files changed, 71 insertions, 83 deletions
diff --git a/games-simulation/lincity/Manifest b/games-simulation/lincity/Manifest
index fa6ff8bbf78b..af8bf31433f1 100644
--- a/games-simulation/lincity/Manifest
+++ b/games-simulation/lincity/Manifest
@@ -1 +1,2 @@
DIST lincity-1.13.1.tar.gz 1064236 BLAKE2B 1172ced3255048f3132f85cd9ae994c7e0558170f7e7a24909af1856669c4ad90d57acd76f330fb556656ed74843dda159005350760fc059c6b184cedf1e9393 SHA512 bc4ee7a1642b1efa25f9edaabd3aeb52d1ca1d016735c5094586f52fda3ec4e9080ff35fe518c1ccbfad9fd54babb370f4b9b6a158b4d2f43b7182155084eefc
+DIST lincity.png 5377 BLAKE2B 2238140719a8c1b094fbe6d7b52b9224245f2c36f970e04aa3fcaf6090409145f17dad2c2a83f6528e695fd9d26d9c053c45978502b7e44f73cf25719d7ed3aa SHA512 40a8955fdc8397662ef0d084163e7dcad59e278429792bd7096e193a0d04791c2355a0dbd2c1f72a032bbfc71bc4e27e37a3d0d4e82de8e7170bb70205d983a3
diff --git a/games-simulation/lincity/files/lincity-1.13.1-build.patch b/games-simulation/lincity/files/lincity-1.13.1-build.patch
index f7f41f954baf..a5244b5387f3 100644
--- a/games-simulation/lincity/files/lincity-1.13.1-build.patch
+++ b/games-simulation/lincity/files/lincity-1.13.1-build.patch
@@ -1,16 +1,5 @@
---- lincity-1.13.1.orig/intl/Makefile.in
-+++ lincity-1.13.1/intl/Makefile.in
-@@ -32,7 +32,7 @@
- libdir = @libdir@
- includedir = @includedir@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/intl
- aliaspath = $(localedir)
- subdir = intl
---- lincity-1.13.1.orig/mouse.c
-+++ lincity-1.13.1/mouse.c
+--- a/mouse.c
++++ b/mouse.c
@@ -1057,7 +1057,7 @@
and set to 1 if the existing transport if the more expensive sort
(e.g. GROUP_RAIL when overwriting GROUP_ROAD).
@@ -20,8 +9,8 @@
mt_erase(int x, int y)
{
if (x < 0 || y < 0 || x >= WORLD_SIDE_LEN || y >= WORLD_SIDE_LEN)
---- lincity-1.13.1.orig/pixmap.c
-+++ lincity-1.13.1/pixmap.c
+--- a/pixmap.c
++++ b/pixmap.c
@@ -390,7 +390,7 @@
likes it in the file. Still need to fix this in autoconf,
but for now this will do. */
@@ -31,8 +20,8 @@
pixmap_index (int x, int y)
{
return y*pixmap_width + x;
---- lincity-1.13.1.orig/pixmap.h
-+++ lincity-1.13.1/pixmap.h
+--- a/pixmap.h
++++ b/pixmap.h
@@ -19,7 +19,7 @@
void initialize_pixmap (void);
void resize_pixmap (int new_width, int new_height);
@@ -51,19 +40,8 @@
pixmap_index (int x, int y) {
return y*pixmap_width + x;
}
---- lincity-1.13.1.orig/po/Makefile.in.in
-+++ lincity-1.13.1/po/Makefile.in.in
-@@ -21,7 +21,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = /usr/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-
- INSTALL = @INSTALL@
---- lincity-1.13.1.orig/readpng.c
-+++ lincity-1.13.1/readpng.c
+--- a/readpng.c
++++ b/readpng.c
@@ -3,6 +3,7 @@
* This file is part of lincity (see COPYRIGHT for copyright information).
* ---------------------------------------------------------------------- */
diff --git a/games-simulation/lincity/lincity-1.13.1-r1.ebuild b/games-simulation/lincity/lincity-1.13.1-r1.ebuild
deleted file mode 100644
index 6479c984045d..000000000000
--- a/games-simulation/lincity/lincity-1.13.1-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils flag-o-matic
-
-DESCRIPTION="city/country simulation game for X and Linux SVGALib"
-HOMEPAGE="http://lincity.sourceforge.net/"
-SRC_URI="mirror://sourceforge/lincity/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-# dep fix (bug #82318)
-RDEPEND="media-libs/libpng:0
- x11-libs/libSM
- x11-libs/libXext
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-gcc-10.patch
-)
-
-src_prepare() {
- default
-
- append-cflags -std=gnu89 # build with gcc5 (bug #570574)
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- --with-gzip \
- --with-x
-}
-
-src_compile() {
- # build system logic is severely broken
- emake
- emake X_PROGS
-}
-
-src_install() {
- default
- dodoc Acknowledgements CHANGES README* TODO
- make_desktop_entry xlincity Lincity
- dobin xlincity
-}
diff --git a/games-simulation/lincity/lincity-1.13.1-r2.ebuild b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
new file mode 100644
index 000000000000..f1cec025ba8f
--- /dev/null
+++ b/games-simulation/lincity/lincity-1.13.1-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic
+
+DESCRIPTION="City simulation game for X"
+HOMEPAGE="http://lincity.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/lincity/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libpng:=
+ virtual/libintl
+ x11-libs/libXext"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
+
+src_configure() {
+ append-cflags -std=gnu89 # build with gcc5 (bug #570574)
+
+ local econfargs=(
+ --with-gzip
+ --with-x
+ --without-svga
+ ac_cv_lib_ICE_IceConnectionNumber=no # not actually used
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_compile() {
+ emake
+ emake X_PROGS
+}
+
+src_install() {
+ default
+
+ dobin x${PN}
+
+ newman {,x}${PN}.6
+ rm "${ED}"/usr/share/man/man6/${PN}.6
+
+ dodoc Acknowledgements
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry x${PN} ${PN^}
+}