summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-server/bf1942-lnxded
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-server/bf1942-lnxded')
-rw-r--r--games-server/bf1942-lnxded/Manifest2
-rw-r--r--games-server/bf1942-lnxded/bf1942-lnxded-1.61.ebuild43
-rw-r--r--games-server/bf1942-lnxded/files/bf1942-lnxded3
-rw-r--r--games-server/bf1942-lnxded/metadata.xml5
4 files changed, 53 insertions, 0 deletions
diff --git a/games-server/bf1942-lnxded/Manifest b/games-server/bf1942-lnxded/Manifest
new file mode 100644
index 000000000000..c8acc6831ce0
--- /dev/null
+++ b/games-server/bf1942-lnxded/Manifest
@@ -0,0 +1,2 @@
+DIST bf1942-update-1.61.tar.gz 7768635 SHA256 6c60b6af994fba9e98f8e3a20ca04602f6f0ad2b40b4c549441918217bc02160 SHA512 041c1ad03daab592b799dec1560e15156e1da583919aa270220d53d308b5c1b8e7da771176eea6e3e1558407dbad37388d480199847c68ecf94b58f29d64a26b WHIRLPOOL 0d1e29b491821e349c7e586e2eea8186c7c6999f682c5a60ef4d6bf94f8a180d58b97c8ccea8b48b260f602fb17e775314549e79f6b12d2118203bc10a4a244c
+DIST bf1942_lnxded-1.6-rc2.run 108138508 SHA256 ca6e754a028e8d12a4f3efbbc90892d979035be7d144de1f64d99884902568f3 SHA512 9171eb8f729bd36fc76133563201332d91e434aa6a54813eb0ec5278f04e7132d4e5b74c92d69ad1e542c37a586aae6ee8d12b2e92d5a853d2682de530ad1db1 WHIRLPOOL 2cfb858500431c584f2c0b5a4ebc495239909240db716f28179f8b900fd7c17336fa2b5eb50f7eaa41662523bebe65eebeba550d93bdeaaa79b34574f6178da7
diff --git a/games-server/bf1942-lnxded/bf1942-lnxded-1.61.ebuild b/games-server/bf1942-lnxded/bf1942-lnxded-1.61.ebuild
new file mode 100644
index 000000000000..c400aedd26a0
--- /dev/null
+++ b/games-server/bf1942-lnxded/bf1942-lnxded-1.61.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="dedicated server for Battlefield 1942"
+HOMEPAGE="http://www.battlefield.com/battlefield-1942"
+SRC_URI="http://ftp.games.skynet.be/pub/misc/${PN/-/_}-1.6-rc2.run
+ http://ftp.games.skynet.be/pub/misc/bf1942-update-${PV}.tar.gz"
+
+LICENSE="bf1942-lnxded"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+RESTRICT="mirror bindist strip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/bf1942
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir}/*.so ${dir}/bf1942_lnxded.*"
+
+src_unpack() {
+ mkdir bf1942 && cd bf1942
+ unpack_makeself ${PN/-/_}-1.6-rc2.run
+ cd ..
+ unpack bf1942-update-${PV}.tar.gz
+}
+
+src_install() {
+ dodir "${dir}"
+ mv -f "${S}"/bf1942/* "${S}" || die
+ rm -rf "${S}"/bf1942 || die
+
+ mv "${S}"/* "${Ddir}" || die
+ dosym bf1942_lnxded.dynamic "${dir}"/bf1942_lnxded
+ games_make_wrapper ${PN} ./bf1942_lnxded "${dir}"
+
+ prepgamesdirs
+}
diff --git a/games-server/bf1942-lnxded/files/bf1942-lnxded b/games-server/bf1942-lnxded/files/bf1942-lnxded
new file mode 100644
index 000000000000..256199b8b8be
--- /dev/null
+++ b/games-server/bf1942-lnxded/files/bf1942-lnxded
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec ./bf1942_lnxded "$@"
diff --git a/games-server/bf1942-lnxded/metadata.xml b/games-server/bf1942-lnxded/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-server/bf1942-lnxded/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>