summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-05 21:55:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-05 22:33:07 -0400
commit4aa71a030a8a8e4bfe8905bcbfc43a4e9a88ea44 (patch)
treee7b61bd1341f76b59015430d907758ce08ae4631 /games-rpg/freedroid
parentgames-rpg/freedroid: add github remote-id (diff)
downloadgentoo-4aa71a030a8a8e4bfe8905bcbfc43a4e9a88ea44.tar.gz
gentoo-4aa71a030a8a8e4bfe8905bcbfc43a4e9a88ea44.tar.bz2
gentoo-4aa71a030a8a8e4bfe8905bcbfc43a4e9a88ea44.zip
games-rpg/freedroid: add 1.2.1, EAPI-7 bump
- switch homepage to github as old pages are dedicated to freedroidrpg - new dep on media-libs/sdl-gfx - re-arrange depends for build-only checks Upstream fixed -fno-common issues wrt bug #791091 Closes: https://bugs.gentoo.org/791091 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-rpg/freedroid')
-rw-r--r--games-rpg/freedroid/Manifest1
-rw-r--r--games-rpg/freedroid/freedroid-1.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/games-rpg/freedroid/Manifest b/games-rpg/freedroid/Manifest
index 926229bb607c..77dbc1787e40 100644
--- a/games-rpg/freedroid/Manifest
+++ b/games-rpg/freedroid/Manifest
@@ -1 +1,2 @@
DIST freedroid-1.0.2.tar.gz 4819173 BLAKE2B 9548cc350010eff47ca13b8b4fd6b1082f16e1fe41bad5c2359aecd7834ef22b27adc90d1d33564edc63a592ffa6934224a0ee16784cf736b98fcb56d287229a SHA512 cfafa4af86a2007fcf761b51e6c7dcc6dc40f4513057413901fede41b7a436b9c8cf7c3e5c29130e5410fab640ffbdc8100043a442555e862acffe9f33086be1
+DIST freedroid-1.2.1.tar.gz 5875869 BLAKE2B fab7dfb16e421394b9b0564a29a2e438152cd3d8a5527e3581823edec174986df473040d58c705765ba50b4b73105a348d39f9e61bb0721bb742c70838cdef34 SHA512 4de2174935e432f6dc4fa3a0fb5efff9bed59ba25593c7860edbddbaea77875a490c3f1e11042b57f0bb72158a3a28e111bf53bb0d10bbf051f67717d4547913
diff --git a/games-rpg/freedroid/freedroid-1.2.1.ebuild b/games-rpg/freedroid/freedroid-1.2.1.ebuild
new file mode 100644
index 000000000000..abc1f4b7f8a6
--- /dev/null
+++ b/games-rpg/freedroid/freedroid-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="The original Freedroid, a clone of the C64 classic Paradroid"
+HOMEPAGE="https://github.com/ReinhardPrix/FreedroidClassic"
+SRC_URI="https://github.com/ReinhardPrix/FreedroidClassic/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FreedroidClassic-release-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[joystick,sound,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod,vorbis]"
+DEPEND="
+ ${RDEPEND}
+ media-libs/libpng
+ media-libs/libvorbis
+ sys-libs/zlib
+ virtual/jpeg"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newicon graphics/paraicon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} Freedroid ${PN} "Game;"
+}