summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2021-03-08 15:16:52 -0500
committerSam James <sam@gentoo.org>2021-04-05 17:45:43 +0000
commit7f46094833b2f839c99bae1c3cbc35940fabbd9c (patch)
tree976b4c707924f306a8d0b274b18c4d2dcbb97103 /games-roguelike
parentgames-roguelike/hengband: fix patch to work with EAPI 7 (diff)
downloadgentoo-7f46094833b2f839c99bae1c3cbc35940fabbd9c.tar.gz
gentoo-7f46094833b2f839c99bae1c3cbc35940fabbd9c.tar.bz2
gentoo-7f46094833b2f839c99bae1c3cbc35940fabbd9c.zip
games-roguelike/adom: remove games.eclass, update to EAPI 7
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/adom/adom-1.1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-roguelike/adom/adom-1.1.1-r1.ebuild b/games-roguelike/adom/adom-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..46b385a623a8
--- /dev/null
+++ b/games-roguelike/adom/adom-1.1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
+HOMEPAGE="https://www.adom.de/"
+SRC_URI="https://www.adom.de/adom/download/linux/${P//.}-elf.tar.gz"
+
+LICENSE="adom"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip" #bug #137340
+
+RDEPEND="sys-libs/ncurses-compat:5[abi_x86_32(-)]"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ exeinto "/opt/bin"
+ doexe adom
+
+ keepdir "/var/games/${PN}"
+ echo "/var/games/${PN}" > adom_ds.cfg
+ insinto /etc
+ doins adom_ds.cfg
+
+ edos2unix adomfaq.txt
+ dodoc adomfaq.txt manual.doc readme.1st
+}