summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/xlogical
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/xlogical')
-rw-r--r--games-puzzle/xlogical/Manifest2
-rw-r--r--games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch49
-rw-r--r--games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch51
-rw-r--r--games-puzzle/xlogical/metadata.xml12
-rw-r--r--games-puzzle/xlogical/xlogical-1.0.7.ebuild60
5 files changed, 174 insertions, 0 deletions
diff --git a/games-puzzle/xlogical/Manifest b/games-puzzle/xlogical/Manifest
new file mode 100644
index 000000000000..e21876fc56b1
--- /dev/null
+++ b/games-puzzle/xlogical/Manifest
@@ -0,0 +1,2 @@
+DIST xlogical-1.0-7.tar.bz2 1853575 SHA256 166d227770dcb7d94138f844a8a81380eff3fac7f564274bb2c66ae974e8e7ca SHA512 b47aadff91a7d3057fe8657bdda5c16a910f84f6d324bee82f1beba55de7faf6a599231c8d53ed68cc30f9edfe18f57f31dfc9fe06b8e03fa6120905f37c290d WHIRLPOOL 97c4b236156257a368b7687731da147f17643ca99c729e520e18fde3837c943e990009c7fe951cb1f7739bcfe6587162b0edd7a8773f1c1af7da0cc699788c96
+DIST xlogical_gfx.zip 347801 SHA256 1d6f97ad3cbcb7b78d3e3594643195d6457ab7ca613ccabd6256a5fe13a98f49 SHA512 14322ae1c8fb7f50513ef47e05372c5dc1ec1b658b33c53477e6b05bbee1de0250b21127891f205d16adc386e7ce37c4b834a62794ee105754b97e49eb5d2a42 WHIRLPOOL 5b33c7603b709c97975d28b264417e1645eeebfb9112d4ec6a84c689fd4bff0ade77188896615b77ec8ab764f61ca1e01ef6075acb25d82a114af32638ad1a6c
diff --git a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch
new file mode 100644
index 000000000000..19cd188b0e0e
--- /dev/null
+++ b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc41.patch
@@ -0,0 +1,49 @@
+--- properties.h.old 2007-01-11 17:33:45.000000000 +0100
++++ properties.h 2007-01-11 17:34:32.000000000 +0100
+@@ -33,9 +33,7 @@
+ #include <map>
+ #include <string>
+
+-#ifdef WIN32
+ using namespace std;
+-#endif
+
+ #include "defs.h"
+
+--- anim.h.old 2007-01-11 17:36:20.000000000 +0100
++++ anim.h 2007-01-11 17:36:37.000000000 +0100
+@@ -27,9 +27,7 @@
+ // Language Includes
+ #include <list>
+
+-#ifdef WIN32
+ using namespace std;
+-#endif
+
+ // Application Includes
+ #include "graph.h"
+--- exception.h.old 2007-01-11 17:37:37.000000000 +0100
++++ exception.h 2007-01-11 17:38:21.000000000 +0100
+@@ -27,10 +27,9 @@
+
+ // Language Includes
+ #include <string>
++#include <iostream>
+
+-#ifdef WIN32
+ using namespace std;
+-#endif
+
+ #define CatchEx(aEx) catch( CXLException aEx )
+ #define ThrowEx(aError) throw CXLException(aError,__FILE__,__LINE__)
+--- gamelogic.cpp.old 2007-01-11 17:38:52.000000000 +0100
++++ gamelogic.cpp 2007-01-11 17:39:12.000000000 +0100
+@@ -154,7 +154,7 @@
+ levelFile = NULL;
+ }
+
+- currentMap = NULL;
++ currentMap = gameLevels.begin();
+
+ playerName = new char[32+1];
+ strcpy( playerName, "nobody" );
diff --git a/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch
new file mode 100644
index 000000000000..4b64fcd67783
--- /dev/null
+++ b/games-puzzle/xlogical/files/xlogical-1.0.7-gcc43.patch
@@ -0,0 +1,51 @@
+--- gamelogic.cpp
++++ gamelogic.cpp
+@@ -25,6 +25,7 @@
+ #include<fstream>
+ #include<cstdio>
+ #include<cctype>
++#include <cstdlib>
+
+ #ifndef WIN32
+ #include<unistd.h>
+--- levelmap.cpp
++++ levelmap.cpp
+@@ -21,6 +21,7 @@
+ ////////////////////////////////////////////////////////////////////////
+
+ // Language Includes
++#include <cstdlib>
+ #include <cstdio>
+ #include <cctype>
+ #include <cstring>
+--- mapedit.cpp
++++ mapedit.cpp
+@@ -26,6 +26,8 @@
+ #include<cstdio>
+ #include<list>
+ #include<vector>
++#include <cstdlib>
++#include <cstring>
+
+ #ifndef WIN32
+ #include<unistd.h>
+--- modlist.cpp
++++ modlist.cpp
+@@ -22,6 +22,7 @@
+
+ #include <iostream>
+ #include <fstream>
++#include <cstdlib>
+
+ #ifdef WIN32
+ #include <afxwin.h>
+--- tile_spinner.cpp
++++ tile_spinner.cpp
+@@ -24,6 +24,7 @@
+
+
+ // Application Includes
++#include <cstdlib>
+ #include "audio.h"
+ #include "properties.h"
+ #include "defs.h"
diff --git a/games-puzzle/xlogical/metadata.xml b/games-puzzle/xlogical/metadata.xml
new file mode 100644
index 000000000000..36ec4edcdc0d
--- /dev/null
+++ b/games-puzzle/xlogical/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+XLogical is a puzzle game based on the Logical! game that was originally
+released by Rainbow Arts on the Commodore Amiga computer.
+</longdescription>
+ <use>
+ <flag name="alt_gfx">Use alternate graphics which are closer to the original Amiga version</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-puzzle/xlogical/xlogical-1.0.7.ebuild b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
new file mode 100644
index 000000000000..b41fb073b0a2
--- /dev/null
+++ b/games-puzzle/xlogical/xlogical-1.0.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools versionator eutils games
+
+MY_PV=$(replace_version_separator 2 '-' )
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="SDL logical clone"
+HOMEPAGE="http://changeling.ixionstudios.com/xlogical/"
+SRC_URI="http://changeling.ixionstudios.com/xlogical/downloads/${MY_P}.tar.bz2
+ alt_gfx? ( http://changeling.ixionstudios.com/xlogical/downloads/xlogical_gfx.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alt_gfx"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}
+ alt_gfx? ( app-arch/unzip )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ if use alt_gfx ; then
+ cd "${S}/images"
+ unpack xlogical_gfx.zip
+ fi
+}
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/d' Makefile.am || die
+ edos2unix properties.h anim.h exception.h
+ epatch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ mv configure.in configure.ac
+ eautoreconf
+}
+
+src_install() {
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ${PN}.{properties,levels} music sound images
+ find "${D}" -name "Makefile*" -exec rm -f '{}' +
+
+ insinto "${GAMES_STATEDIR}"/${PN}
+ doins ${PN}.scores
+ fperms 0660 "${GAMES_STATEDIR}"/${PN}/${PN}.scores
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry ${PN} "Xlogical"
+ prepgamesdirs
+}