summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/swell-foop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/swell-foop')
-rw-r--r--games-puzzle/swell-foop/Manifest2
-rw-r--r--games-puzzle/swell-foop/metadata.xml5
-rw-r--r--games-puzzle/swell-foop/swell-foop-3.14.0.ebuild37
-rw-r--r--games-puzzle/swell-foop/swell-foop-3.16.1.ebuild37
4 files changed, 81 insertions, 0 deletions
diff --git a/games-puzzle/swell-foop/Manifest b/games-puzzle/swell-foop/Manifest
new file mode 100644
index 000000000000..80a317f56435
--- /dev/null
+++ b/games-puzzle/swell-foop/Manifest
@@ -0,0 +1,2 @@
+DIST swell-foop-3.14.0.tar.xz 2336392 SHA256 c52e5c03da5136e47eb04ed58982e93659c7c88411c282b143fc347350ec6dca SHA512 80b9546dfe10d637ca087f912c86c82100099505f7b216c710208bdd91d4a41744147548bb92f90cade103e182cb0da86ef9edd0eef624184024550ac5024d53 WHIRLPOOL fb082bb6233d22812244bd8099fb5c7f66d91b03e11a22e3ca39debac71f9001cdab371a2294cdda9a8c8a048f7c4ec219688279981c1d8e3666a50294e1ae4d
+DIST swell-foop-3.16.1.tar.xz 2372956 SHA256 8e7f09f8c28e3232a5b6726568d1a463c1a2af89cf030d7542ab612d99ac122e SHA512 3e2e024ca302273ba8d6aac7aa1bef0679388b3c67712ed34f0b120ad8bee7670c164098ec2f2ee88a248abfb95957a4a04bb9731be0fcb628da65ebf71a3b59 WHIRLPOOL 3dc1c1c334377881729f0532bf452f0ce538c279230ba2699a42ab6d0a20b80a914766b66fd2644f7439cab3dddac953eefdcd65fe3b935fd994479c3ba412c2
diff --git a/games-puzzle/swell-foop/metadata.xml b/games-puzzle/swell-foop/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/games-puzzle/swell-foop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>
diff --git a/games-puzzle/swell-foop/swell-foop-3.14.0.ebuild b/games-puzzle/swell-foop/swell-foop-3.14.0.ebuild
new file mode 100644
index 000000000000..7f016fdadab6
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-3.14.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome-games vala
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=media-libs/clutter-1.14:1.0
+ >=media-libs/clutter-gtk-1.5:1.0
+ >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}
diff --git a/games-puzzle/swell-foop/swell-foop-3.16.1.ebuild b/games-puzzle/swell-foop/swell-foop-3.16.1.ebuild
new file mode 100644
index 000000000000..ed3670db22fa
--- /dev/null
+++ b/games-puzzle/swell-foop/swell-foop-3.16.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome-games vala
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=media-libs/clutter-1.14:1.0
+ >=media-libs/clutter-gtk-1.5:1.0
+ >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome-games_src_prepare
+ vala_src_prepare
+}