summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/neverball/neverball-1.6.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/neverball/neverball-1.6.0.ebuild')
-rw-r--r--games-puzzle/neverball/neverball-1.6.0.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/games-puzzle/neverball/neverball-1.6.0.ebuild b/games-puzzle/neverball/neverball-1.6.0.ebuild
new file mode 100644
index 000000000000..73ca285c870e
--- /dev/null
+++ b/games-puzzle/neverball/neverball-1.6.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Clone of Super Monkey Ball using SDL/OpenGL"
+HOMEPAGE="http://neverball.org/"
+SRC_URI="http://neverball.org/${P}.tar.gz"
+
+LICENSE="GPL-2+ IJG"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="media-libs/libsdl2[sound,joystick,opengl,video]
+ media-libs/sdl2-ttf
+ media-libs/libpng:0
+ virtual/jpeg
+ media-libs/libvorbis
+ virtual/opengl
+ dev-games/physfs
+ media-fonts/dejavu
+ media-fonts/wqy-microhei
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e 's:mapc:neverball-mapc:g' \
+ -e 's:MAPC:NEVERBALL-MAPC:g' \
+ -e '1 s/ 1 / 6 /' \
+ dist/mapc.1 || die
+ sed -i \
+ -e '/CFLAGS.*O2/s:-O2:$(E_CFLAGS):' \
+ -e '/CXXFLAGS.*O2/s:-O2:$(E_CXXFLAGS):' \
+ -e "/^MAPC_TARG/s/mapc/${PN}-mapc/" \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ ENABLE_NLS=$(use nls && echo 1 || echo 0) \
+ E_CFLAGS="${CFLAGS}" \
+ E_CXXFLAGS="${CXXFLAGS}" \
+ LOCALEDIR=/usr/share/locale \
+ DATADIR="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ local font
+
+ dogamesbin ${PN}-mapc neverball neverputt
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/*
+ for font in DejaVuSans-Bold.ttf wqy-microhei.ttc
+ do
+ rm -f "${D}${GAMES_DATADIR}/${PN}"/ttf/${font}
+ dosym /usr/share/fonts/*/${font} \
+ "${GAMES_DATADIR}/${PN}"/ttf/${font}
+ done
+ if [[ -d locale ]] ; then
+ insinto /usr/share
+ doins -r locale
+ fi
+ dodoc doc/{authors.txt,manual.txt,release-notes.md} README.md
+
+ local res name
+ for name in ball putt; do
+ for res in 16 32 64 128 256; do
+ newicon -s ${res} dist/never${name}_${res}.png never${name}.png
+ done
+ done
+
+ doman dist/*.6
+ newman dist/mapc.1 neverball-mapc.6
+ make_desktop_entry neverball Neverball
+ make_desktop_entry neverputt Neverputt neverputt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ games_pkg_postinst
+ elog "${P} will overwrite existing high-score files, so back them up if"
+ elog "you want to preserve your old scores and progress."
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}